SR20DE Heating up - SR20 Forum
Nissan SR20 Forum Nissan SR20 Forum Header Right
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

Welcome to the SR20 Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

» Log in
User Name:

Password:

Not a member yet?
Register Now!
» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   SR20 Forum > Main Forums > General SR20



Sr20Forum.com is the premier Nissan SR20 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 11-26-2012, 03:57 AM   #1 (permalink)
SE-R Newbie

 
Join Date: Jan 2012
Location: South Africa

Feedback Score: 0 reviews
SR20DE Heating up

Hi there. My SR20DE startwith with bubbling in the coolant overflow bottle then temp went till red before i switched car off. I replaced thermostat and radiator cap. Car no longer heated up, but after a week or two I heard bubbling again. tried bleedig then seemed to be fine for a while till car heated up again. Temp was on read, so i put interior heater fan on, but only cold air came out. I replaced colant radiator and that was fine for 2 days, then heated up gain and again even though both radiator pipes were warm, only cold air blow inside car. bled the system, seems to be ok again. Anyone have same experience and some advice for me pls????
Ebrahim is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-2012, 10:47 AM   #2 (permalink)
SE-R Newbie

 
Join Date: Oct 2011
Location: houston texas

Feedback Score: 0 reviews
is the water pump good *** when my water pump went out on my sentra no heat came from the vents
davidpalmer88 is offline   Reply With Quote
Old 11-27-2012, 01:27 AM   #3 (permalink)
SE-R Newbie

 
Join Date: Jan 2012
Location: South Africa

Feedback Score: 0 reviews
How can I check water pump? I drove the car yesterday & this morning in traffic and temp is normal & no bubbling in coolant bottle. I'm assuming that there was air in the system, but I'll have to wait & see.
Ebrahim is offline   Reply With Quote
Old 11-27-2012, 10:37 AM   #4 (permalink)
SE-R Newbie

 
Join Date: Oct 2011
Location: houston texas

Feedback Score: 0 reviews
check the water pump for water coming from under it or check your thermostat they can get stuck open or closed that can cause your car to over heat and check to see if the wires on the fan are tight ive had those problems with mine my fan wouldnt turn on all the time let me know ill keep trying to think of other things
davidpalmer88 is offline   Reply With Quote
Old 12-09-2012, 05:55 AM   #5 (permalink)
SE-R Newbie

 
Join Date: Jan 2012
Location: South Africa

Feedback Score: 0 reviews
There does open, both pipes are warm, fan goes on. My temperature went to red again, when I put interior heater on, the air is cold even though the water is boiling. I'm going to remove & maybe replace water pump if necessary. I'm running out of ideas & getting frustrated.
Ebrahim is offline   Reply With Quote
Old 12-10-2012, 12:00 PM   #6 (permalink)
SE-R Newbie

 
Join Date: Oct 2011
Location: houston texas

Feedback Score: 0 reviews
flush

try to get your system flushed before changing the water pump maybe you have a blockage in one of the hoses or the blades on the water pump are messed up and not letting the coolant flow any you said your fans turn on
davidpalmer88 is offline   Reply With Quote
Old 12-12-2012, 01:29 AM   #7 (permalink)
SE-R Newbie

 
Join Date: Jan 2012
Location: South Africa

Feedback Score: 0 reviews
I changed water pump, the car was fine for a few hours then temp went up again. Both hoses going to radiator were hot< the fan was on & there was heat went i put heater on. I'm totally puzzled>>>
Ebrahim is offline   Reply With Quote
Old 12-12-2012, 10:51 AM   #8 (permalink)
SE-R Newbie

 
Join Date: Oct 2011
Location: houston texas

Feedback Score: 0 reviews
did you blow your head gasket? so after changing the water pump the heater works now i would say take off the hoses and check them and replace the thermostat
davidpalmer88 is offline   Reply With Quote
Old 01-04-2013, 02:27 AM   #9 (permalink)
FTW

 
Join Date: Sep 2006
Location: Buena Park,California

Feedback Score: 9 reviews
sounds like your heater valve is stuck or your cable that is suppose to open and close it has broken. if its a g20 with digital you have a electric motor turning the valve on and off. regardless of the heater not working on your car, sounds like you have a blown headgasket and losing compression and being sent out to your coolant passage hence blowing out air through the coolant reservoir.
__________________
1967 Datsun Roadster 1600- Weekend toy
1991 Nissan Sentra B13 SE-R- avenir powered.- Now VVL- now Avenir Powered Again.
(SOLD)1996 Nissan 200sx B14 SE-R TEAL- VVL- shell now boosted missed dearly
1996 Nissan 200sx- VVL- super sleeper
Joaquin714 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  SR20 Forum > Main Forums > General SR20


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:26 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
© The SR20 Forum - Content from this site may not be used without permission