Gas guage after half tank - SR20 Forum
Reply
 
Thread Tools
#1 (permalink) Old 07-17-2007, 07:24 PM
Im Not A Chick
 
Join Date: Sep 2006
Location: Hardford County Maryland
Posts: 3,306
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
(Thread Starter)
Gas guage after half tank

Is it just me or does my gas gauge seem to go down faster after it passes half tank then to full to half tank?? when i fill my gas all the way up it seems like i can drive 2 or 3 days before it even touches half a tank. but after half it drops down super fast!!


its like its better to fill your gas tank all the way then just to put 10 bucks or so in it cause it seems to go alot faster....... i have tried to test and see how long i can go with my light comming on but it never does and im to scared to try(maybe my light dont work?)

does anybody else have this problem?

Last edited by jen36; 07-17-2007 at 07:26 PM.
jen36 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-17-2007, 11:15 PM
Im Not A Chick
 
Join Date: Sep 2006
Location: Hardford County Maryland
Posts: 3,306
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
(Thread Starter)
nobody huh?
jen36 is offline  
#3 (permalink) Old 07-17-2007, 11:30 PM
the ONLY nx in PALATINE!!
 
Join Date: Feb 2006
Location: schaumburg!!!!!, illinois
Posts: 868
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
i got 50 miles with the light on...prior to getting a new02 sensr.....from .25 tank to when the light came on i got 30 -37 miles...

after that i replaced the o2 sensr and got 65-70 miles from.25 tank till when the light came on

almost double!
pedronx2k is offline  
#4 (permalink) Old 07-17-2007, 11:30 PM
the ONLY nx in PALATINE!!
 
Join Date: Feb 2006
Location: schaumburg!!!!!, illinois
Posts: 868
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
pedronx2k is offline  
#5 (permalink) Old 07-18-2007, 12:01 AM
Squeaky Cleean!
 
nx-r_waz's Avatar
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 617
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by jen36 View Post
Is it just me or does my gas gauge seem to go down faster after it passes half tank then to full to half tank?? when i fill my gas all the way up it seems like i can drive 2 or 3 days before it even touches half a tank. but after half it drops down super fast!!
Yup, mine does that too, as did my N15 Pulsar I used to own (pretty much your B14).

***. NX-R Coupe - SR20DE Power....
nx-r_waz is offline  
#6 (permalink) Old 07-18-2007, 12:11 AM
keeps on going
 
Join Date: Nov 2004
Location: Bmore, MD
Posts: 379
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
same here...ive always wondered if this happens to anyone else...no idea why though. I always guessed that it was an inaccurate fuel level sending unit.
pwr2max is offline  
#7 (permalink) Old 07-18-2007, 01:09 AM
SE-R Nut
 
Join Date: Sep 2003
Posts: 1,311
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Mine does the same. Every car I've ever had the last half of the tank went quicker than the first.

I'll get like 100 miles on the first quarter tank, then 75 on the next, then 125 on the last half of the tank. I've never hit gas light, most I've ever put in is 11 gallons, I'm not sure if the gas light works, and I don't wann find out. Running out of gas sounds like a huge avoidable pain in the ass.
skcusloa is offline  
#8 (permalink) Old 07-18-2007, 01:19 AM
3 NX2000's
 
NX2KTPR's Avatar
 
Join Date: Aug 2001
Location: Atlanta, GA
Posts: 717
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
I regularly hit 1/2 tank with 150 to 170 miles on the trip odometer.
Then 240 to 260 at the "1/4" mark (really, its more like a 1/5 mark).
The low fuel light comes on at 308 to 320 miles and I had better be filling up at 340 to 360 miles depending on the type of driving I've been doing (28 to 29 mpg in mixed driving, 31 to 33 mpg on the highway.)

Tim Rogers
'93 NX2K- Sapphire Blue, HS Gen 4, JWT S3's, Ported & Polished, P/R CAI, JUN Flywheel, Coil-over / AGXs, 15X7 RPO-2's, 205/50/15's.
'91 NX2K- Black, parts car
'92 NX2K- All out SCCA Improved Touring A race car.
Yes, it's Greg Amy's former car.
And yes, I've broken it...
NX2KTPR is offline  
#9 (permalink) Old 07-18-2007, 01:44 AM
NX Cruiser
 
Join Date: Feb 2006
Location: Fort Washington, Md
Posts: 1,031
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 33 reviews
Tim,
You are getting great gas mileage. Wish I was getting that kind of mileage.

My fuel gauge dont work the way everyone here is describing. From full to 3/4 moves fast at 50-60 miles, half tank at 130-140 miles, and empty at 270-290 miles. So, my gauge goes to 3/4 tank really fast and slow until empty. Kinda strange. Im running Shell 87 grade (89 & 93 grade only gives minimum gas mileage improvements).

1993 NX2000 -- JDM DE, ActiveTuning Grnd Kit & RSTB, Cusco FSTB, Progress Rear Swaybar, Hyperco/AGX,
Full SS 2.5" VRS SS Catback, SSAC 2.5" header/flexpipe, JWT Pop-Charger, EDM Headlamp, Yellow Fogs, & Power Leather Seats.
DC Scotty is offline  
#10 (permalink) Old 07-18-2007, 06:21 AM
Stuck on an island
 
Join Date: May 2000
Location: Victoria British Columbia
Posts: 1,284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I get 400 km ( 250 Miles ) to about 38/ 40 L of gas (10/10.5 gallons) on the HWY
all city I get ruffly 310km to the same amount of fuel. 350km mixed
thats at E on my gas gage, I know its a 50 L ( 13 gallon ) tank but I don't want to find out the hard way if my gas light works or not.
From half to quarter moves the slowest the last quarter to E happens really fast with in 20 30 km rest moves with in a 50 to 100ish km range to the marks.

279 hp @ 17psi
Nx 2000 : It sticks to the road like bubble gum to hot asphalt
Nick is offline  
#11 (permalink) Old 07-18-2007, 07:22 AM
CDN GTiR
 
Join Date: Jul 2007
Location: Saskatoon, SK, Canada
Posts: 161
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
hm. In my GTiR the 1st half of the guage goes quickly. The last half I know I can get in another 250 kms.
CanadianR is offline  
#12 (permalink) Old 07-18-2007, 11:24 AM
Don't eat yellow snow
 
Join Date: Apr 2002
Location: Fort Mill, SC
Posts: 739
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
This is a common issue with B13's - classics and NXs. I think its rare if you don't have this issue with a NX or SE-R, its something with the part that reads the gas levels.

I just got 360 miles on one tank, mostly hwy at 80 mph. Filled up and it took 11.6 gallons. I definitely like to push the tank to the limit. My yellow warning light has been on for 40 miles before I got scared of being stranded with no gas. Basically, the NX is capable of getting great gas mileage which is why I chose it for my daily driver and its mostly stock. That and t-tops for the long drives home on Fridays. I haven't put in a new O2 sensor yet eithier...my wifes EX civic gets about 38 mpg on the same drive per tank with 16" rims.

I got about 3 mpg better when I put the WAI on the engine. I bet its because it sucks up more hot air which should yield better gas mileage and slower ETAs.

2001 black Lexus IS300
Buckwilly is offline  
#13 (permalink) Old 07-18-2007, 04:28 PM
Im Not A Chick
 
Join Date: Sep 2006
Location: Hardford County Maryland
Posts: 3,306
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
(Thread Starter)
i dunno right now my gauge is reading bearly under the E and my light still has not come on.. i dunno if it works or not. i would just haul around a gas tank just to see but i dont want nuthing to spill or the fumes of the gar in the car.. other then that i have no idea it ifs just a bad reading or thats it.. the best i had was 267 before i got scared caus my light didnt come on and i filled up because it was like straight on E.. maybe i will do this lilttle experiment to see if my light works
jen36 is offline  
#14 (permalink) Old 07-18-2007, 04:44 PM
broke, busted and rusted
 
Join Date: Apr 2002
Location: g-burg, MD
Posts: 2,095
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 3 reviews
My car does the same thing, I always get way more milage on the first half tank

i program my heart to beat break beats and hum basslines in exhalation - matter, verse, spirit
TELL THE TRUTH!
Fonque is offline  
#15 (permalink) Old 07-18-2007, 05:04 PM
Don't eat yellow snow
 
Join Date: Apr 2002
Location: Fort Mill, SC
Posts: 739
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by jen36 View Post
i dunno right now my gauge is reading bearly under the E and my light still has not come on.. i dunno if it works or not. i would just haul around a gas tank just to see but i dont want nuthing to spill or the fumes of the gar in the car.. other then that i have no idea it ifs just a bad reading or thats it.. the best i had was 267 before i got scared caus my light didnt come on and i filled up because it was like straight on E.. maybe i will do this lilttle experiment to see if my light works

Well, I have taken my tank to 11.6 gallons to fill up, if you only are putting in 10.5 gallons at your typical fill up then you most likely are not taking the tank to the empty tank warning light threshhold. My fuel low warning light was on for the last 40 miles of that fill up I mentioned previously. The light did not go on until well under the the E hash on the gas gauge. This is my third sr20de vehicle that has had this issue. A search on this forum will show that this is a common issue with these cars.

2001 black Lexus IS300

Last edited by Buckwilly; 07-18-2007 at 05:05 PM.
Buckwilly is offline  
#16 (permalink) Old 07-18-2007, 05:46 PM
Im Not A Chick
 
Join Date: Sep 2006
Location: Hardford County Maryland
Posts: 3,306
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
(Thread Starter)
ok so i ran around to do some errands and what do you ***.. my warning light turned on !! it was very fait at first and it was going on off and on everytime i hit a bump so at first i thought i was just seeing things. i had to put my had over the light to actually see the glow of it.. i guess it kind of excited me that it works lol......and the gauge ran just under the E just like it stated above..............
jen36 is offline  
#17 (permalink) Old 07-18-2007, 06:48 PM
Deviled Egg!
 
XxToKeSxX's Avatar
 
Join Date: Jul 2005
Location: SW Ohi-hoe
Posts: 6,321
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 44 reviews
Quote:
Originally Posted by jen36 View Post
Is it just me or does my gas gauge seem to go down faster after it passes half tank then to full to half tank?? when i fill my gas all the way up it seems like i can drive 2 or 3 days before it even touches half a tank. but after half it drops down super fast!!


its like its better to fill your gas tank all the way then just to put 10 bucks or so in it cause it seems to go alot faster....... i have tried to test and see how long i can go with my light comming on but it never does and im to scared to try(maybe my light dont work?)

does anybody else have this problem?
It's not necessarily a problem... just the way the fuel gauge reads... check it.

This isn't exact, but if you can - picture your gas tank as a closed weir cross section or something...If the bottom width of the tank is smaller than the top width, and the tank level measures the height of the liquid level, the reading isn't necessary linear.

In other words since the liquid level is read from the dial, and not the volume... since the bottom of the tank is angled, the reading will not be linear on the gas gauge. At half level, its not necessarily the same amount of gas as the top half of the tank... which is why it would seem to deplete faster... That is most likely why. If not then sue me.




1993 B13 SE-R!!!! | SR20VE Daily
1996 D21 4x4!!!!!!! | KA24E Bike Hauler
1998 200sx SE-R | SR20DE S3R'd For Sale!!!!
1991 NX-TuRBO | SR20DET Parted Out
1993 NX2000!!!!!!!! | SR20DE Sold
1993 B13 SE-R!!!! | SR20DET Parted Out
1995 240sx BaSe | VQ30DET Sold
1991 240sx SE!!!!! | KA24DE Sold

Shift_Buy Broken & Build...

Last edited by XxToKeSxX; 07-18-2007 at 06:51 PM.
XxToKeSxX is offline  
#18 (permalink) Old 07-18-2007, 08:08 PM
Im Not A Chick
 
Join Date: Sep 2006
Location: Hardford County Maryland
Posts: 3,306
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
(Thread Starter)
hmm very intresting
jen36 is offline  
#19 (permalink) Old 07-18-2007, 08:12 PM
3 NX2000's
 
NX2KTPR's Avatar
 
Join Date: Aug 2001
Location: Atlanta, GA
Posts: 717
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Quote:
Originally Posted by Buckwilly View Post
Well, I have taken my tank to 11.6 gallons to fill up, if you only are putting in 10.5 gallons at your typical fill up then you most likely are not taking the tank to the empty tank warning light threshhold. My fuel low warning light was on for the last 40 miles of that fill up I mentioned previously. The light did not go on until well under the the E hash on the gas gauge. This is my third sr20de vehicle that has had this issue. A search on this forum will show that this is a common issue with these cars.
I just filled up with 12.3 gallons, (357.4 miles, 29.1 MPG) and I probably could have gone another 10 miles or so safely. The fuel light had been flickering on since about 317 miles, was on solid from about 330 miles or so with the needle having just dropped below the E hash. I think the most I've ever put in the tank (by letting the pump click off automatically as I always do) is 12.7.

Of course, YMMV

Tim Rogers
'93 NX2K- Sapphire Blue, HS Gen 4, JWT S3's, Ported & Polished, P/R CAI, JUN Flywheel, Coil-over / AGXs, 15X7 RPO-2's, 205/50/15's.
'91 NX2K- Black, parts car
'92 NX2K- All out SCCA Improved Touring A race car.
Yes, it's Greg Amy's former car.
And yes, I've broken it...
NX2KTPR is offline  
#20 (permalink) Old 07-18-2007, 08:16 PM
3 NX2000's
 
NX2KTPR's Avatar
 
Join Date: Aug 2001
Location: Atlanta, GA
Posts: 717
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Quote:
Originally Posted by Fonque View Post
My car does the same thing, I always get way more milage on the first half tank
Not me, 150 to 170 miles to the half mark, then about another 180 to 200 miles on the second half.
Of course, I also stop filling when the pump automatically clicks off. If you're filling much past that, then you're probably filling the tank (and maybe the filler neck) higher than the sending unit in the tank can read.

Tim Rogers
'93 NX2K- Sapphire Blue, HS Gen 4, JWT S3's, Ported & Polished, P/R CAI, JUN Flywheel, Coil-over / AGXs, 15X7 RPO-2's, 205/50/15's.
'91 NX2K- Black, parts car
'92 NX2K- All out SCCA Improved Touring A race car.
Yes, it's Greg Amy's former car.
And yes, I've broken it...
NX2KTPR is offline  
Sponsored Links
Advertisement
 
Reply

  SR20 Forum > SR20 Powered > NX2000


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome