When I turn on headlights, engine jerks, rpms jump down and car almost dies - SR20 Forum
Nissan SR20 Forum Nissan SR20 Forum Header Right
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

Welcome to the SR20 Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

» Log in
User Name:

Password:

Not a member yet?
Register Now!
» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   SR20 Forum > Main Forums > SR20DE Technical Corner



Sr20Forum.com is the premier Nissan SR20 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 10-28-2005, 12:23 AM   #1 (permalink)
Air Force SE-R freak!!!!!
 
Dick's Avatar

I support the SR20 Forum!
 
Join Date: Oct 2004
Location: Panama City, FL

Feedback Score: 52 reviews
When I turn on headlights, engine jerks, rpms jump down and car almost dies

It happens if I'm driving or at idle and happens about 75% of the time. It's scary!!
If I have the parking lights on and turn the headlights on the same thing happens. RPMs jump down and then back up, stereo turns off (usually) and back on. All interior lights turn off for a second also.
What the hecks going on with my car? Any ideas???
__________________
95' b14 SE-R w/ sr20ve
93' b13 SE-R w/ sr20ve
95' 240sx SE

Where to buy all your b13 and b14 cosmetic modifications>>>>>>www.rapidcustoms.com
Dick is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-28-2005, 01:17 AM   #2 (permalink)
working on it
 
swiss's Avatar

 
Join Date: Jul 2005
Location: TN

Feedback Score: 27 reviews
Hmmm, I remember reading there is an engine control intended to compensate for things that would affect your idle like ac, power steering, lights, etc. I can't remember what it is called, but this may be your problem.
swiss is offline   Reply With Quote
Old 10-28-2005, 07:19 AM   #3 (permalink)
AWD owns me
 
Jaketips42's Avatar

 
Join Date: Dec 2000
Location: Bedford, NH

Feedback Score: 12 reviews
Check your grounds. Install a couple more from engine to body.
__________________
Sporting the GC awaiting EJ20T



Click HERE to see the XE-R project. --- SOLD --- ...

___________________________________Jake T
____________________________________GC Pilot
Subaru stole me from Nissan
Jaketips42 is offline   Reply With Quote
Old 10-28-2005, 09:01 AM   #4 (permalink)
Air Force SE-R freak!!!!!
 
Dick's Avatar

I support the SR20 Forum!
 
Join Date: Oct 2004
Location: Panama City, FL

Feedback Score: 52 reviews
Hmmmm...
Quote:
Originally Posted by 93W91SER
Check your grounds. Install a couple more from engine to body.
Dick is offline   Reply With Quote
Old 10-28-2005, 09:02 AM   #5 (permalink)
www.FAIRTAX.org
 
paNX2K&SE-R's Avatar

I support the SR20 Forum!
 
Join Date: Feb 2001
Location: Pittsburgh

Feedback Score: 93 reviews
Yup it sounds like a ground issue or your voltage regualtor is not functioning right, or your alternator is malfunctioning.
__________________
03.5 G35 Sport 6MT
07 Forester XT Sport 5MT
94 Miata GT28RS powered
93 LS1 240SX Family Project
paNX2K&SE-R is offline   Reply With Quote
Old 10-30-2005, 10:28 AM   #6 (permalink)
SE-R Newbie

 
Join Date: Oct 2005
Location: USVI
Feedback Score: 0 reviews
The voltage regulator on your alternator is definitely malfunctioning.
mwilliams is offline   Reply With Quote
Old 10-30-2005, 11:10 AM   #7 (permalink)
Air Force SE-R freak!!!!!
 
Dick's Avatar

I support the SR20 Forum!
 
Join Date: Oct 2004
Location: Panama City, FL

Feedback Score: 52 reviews
Thanx everyone. I'll be checking the voltage regulator and alternator this week.
Dick is offline   Reply With Quote
Old 10-30-2005, 08:06 PM   #8 (permalink)
-
 
llaprad1's Avatar

I support the SR20 Forum!
 
Join Date: Jul 2001
Location: Nashville, TN

Feedback Score: 12 reviews
Quote:
Originally Posted by AF200SX/SE-R
Thanx everyone. I'll be checking the voltage regulator and alternator this week.
I had a mysterious sputtering only when I opened my door,

Turned out there was a short around the domelight from when I got my headliner redone.
__________________
**************************************************
Louis - 1993 Nissan Sentra SE-R
Rallycross Machine!

**************************************************
llaprad1 is offline   Reply With Quote
Old 11-01-2005, 12:23 AM   #9 (permalink)
Do the non-believers Bad.

 
Join Date: Sep 2004
Location: Clearfield, UT

Feedback Score: 4 reviews
I have the same problem on my Eclipse. This thread just taught me a lot. Thanks panx2k&ser. Wheres the voltage regulator?
__________________
Jerimiah ------

1999 G20 - Boosted.
jerimiah is offline   Reply With Quote
Old 11-01-2005, 12:33 AM   #10 (permalink)
yeah it's a race car
 
back to black's Avatar

 
Join Date: Dec 2004
Location: byron IL

Feedback Score: 5 reviews
that happened to me right before my battery craped out on me
__________________
Talk is cheap
But doing it is expensive
back to black is offline   Reply With Quote
Old 11-01-2005, 06:45 AM   #11 (permalink)
www.FAIRTAX.org
 
paNX2K&SE-R's Avatar

I support the SR20 Forum!
 
Join Date: Feb 2001
Location: Pittsburgh

Feedback Score: 93 reviews
Its integrated into the alternator.

Quote:
Originally Posted by nx2kjl
Thanks panx2k&ser. Wheres the voltage regulator?
paNX2K&SE-R is offline   Reply With Quote
Old 11-01-2005, 06:53 AM   #12 (permalink)
SE-R Geek

 
Join Date: Aug 2001
Location: Alexandria, VA, USA

Feedback Score: 4 reviews
Quote:
Originally Posted by paNX2K&SE-R
Its integrated into the alternator.
I believe when the voltage regulator fails, it will just overcharge the battery. It will put out like 16 volts or so, and the battery will start to spit out acid and eventually die. Doesnt sound like a volt. regulator problem to me.
mpg9999 is offline   Reply With Quote
Old 11-01-2005, 07:22 AM   #13 (permalink)
Air Force SE-R freak!!!!!
 
Dick's Avatar

I support the SR20 Forum!
 
Join Date: Oct 2004
Location: Panama City, FL

Feedback Score: 52 reviews
So it is attched to the alternator?
Quote:
Originally Posted by paNX2K&SE-R
Its integrated into the alternator.
Dick is offline   Reply With Quote
Old 11-01-2005, 10:07 AM   #14 (permalink)
Do the non-believers Bad.

 
Join Date: Sep 2004
Location: Clearfield, UT

Feedback Score: 4 reviews
^^I think it is attached INSIDE the alternator, from what he said.

So it would be fair to say that if you have this problem with your car that its just the alternator?? Sometimes when I go to turn my eclipse on - it wont - but will magically turn on 20 seconds later - is that an alternator too?
jerimiah is offline   Reply With Quote
Old 11-01-2005, 10:14 AM   #15 (permalink)
Lock it up!!!!

 
Join Date: Aug 2002
Location: Ct for now

Feedback Score: 15 reviews
as everyone else says its something with the alternator
__________________
97 200sx Se-r. Back in my possession
12 Wrx 5dr hatch
08 Yamaha R1
11 Lexus IS 250 (wife's ride)
Joes97turboSE-R is offline   Reply With Quote
Old 11-01-2005, 10:18 AM   #16 (permalink)
Do the non-believers Bad.

 
Join Date: Sep 2004
Location: Clearfield, UT

Feedback Score: 4 reviews
Are you refering to my question above yours??
jerimiah is offline   Reply With Quote
Old 11-01-2005, 12:45 PM   #17 (permalink)
AWD owns me
 
Jaketips42's Avatar

 
Join Date: Dec 2000
Location: Bedford, NH

Feedback Score: 12 reviews
Quote:
Originally Posted by AF200SX/SE-R
So it is attched to the alternator?
It is part of the alt, yes. Go to your nearest Sears and get it tested for free.
Jaketips42 is offline   Reply With Quote
Old 11-01-2005, 01:18 PM   #18 (permalink)
Lock it up!!!!

 
Join Date: Aug 2002
Location: Ct for now

Feedback Score: 15 reviews
no sorry
Joes97turboSE-R is offline   Reply With Quote
Old 12-05-2005, 12:59 PM   #19 (permalink)
Air Force SE-R freak!!!!!
 
Dick's Avatar

I support the SR20 Forum!
 
Join Date: Oct 2004
Location: Panama City, FL

Feedback Score: 52 reviews
Ok, I had the battery and the altinator tested this past weekend at AutoZoneand they are both good. My freaking car is getting worse. When the car is warm and I'm sitting at idle, if I press the 2 windows up the car dies. Also, when I'm driving and I turn off my brights, the car jerks and my radio turns off then back on.
I am getting very scared.
Anyone else have any ideas whats wrong with my car???
Dick is offline   Reply With Quote
Old 12-05-2005, 06:34 PM   #20 (permalink)
-
 
llaprad1's Avatar

I support the SR20 Forum!
 
Join Date: Jul 2001
Location: Nashville, TN

Feedback Score: 12 reviews
Chase down a short somewhere.
llaprad1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  SR20 Forum > Main Forums > SR20DE Technical Corner


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 08:30 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
© The SR20 Forum - Content from this site may not be used without permission