Installed new alternator car won't start, just SINGLE CLICK - plz help - SR20 Forum
 
Thread Tools
#1 (permalink) Old 04-29-2010, 08:45 PM
tj.png
 
Join Date: Mar 2005
Location: Lincoln, NE
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
(Thread Starter)
Solved Q/A

Issue was with the oil stick not being in its place.

I hope they have SR20s in heaven

Last edited by ak_47; 08-02-2010 at 01:07 AM.
ak_47 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-30-2010, 05:14 AM
SE-R Newbie
 
Join Date: Apr 2006
Location: Portland
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The single click sounds like its the starter, try banging on the solenoid while somebody tries to crank it over. Check to see if you have power to your fuses, you could have blown a fusible link if it has them. You did have the battery disconnected before you tried to replace the alternator right?
PDX_SER is offline  
#3 (permalink) Old 05-06-2010, 09:43 PM
SE-R Lightweight
 
Join Date: Nov 2006
Location: indio ca (palm springs)
Posts: 352
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
make sure you connected the pig tail right some times it lets you flip it to where power gets ground and you blow the 7.5 fuse in the box marked alt

(\__/)
(O.o )
(> < )
i wanna go fast is offline  
#4 (permalink) Old 05-06-2010, 10:06 PM
SE-R Joe
 
Join Date: Mar 2009
Location: New Jersey
Posts: 495
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 14 reviews
Quote:
Originally Posted by ak_47 View Post
1998 Sentra SE

My brother-in-law helped me install a new alternator to replace the broken one but now the car won't start or lights won't come on at all. Just a single click when I try to turn the key...

Battery is fully charged, fuses are ok would you know what might cause this? If you do please help.

Thanks.
Battery is Dead. It didnt take the charge. try jumpin it
joe92ser is offline  
Sponsored Links
Advertisement
 
Reply

  SR20 Forum > Main Forums > SR20DE Technical Corner


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome