SR20 Forum banner
1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
Hi all.
I've got a 1991 stock G20 with 212,000 miles on the clock. Recently, it's been idling poorly: around 500. It also likes to dip the idle when you put the clutch in. In addition, it has a tendency to buck when at light throttle, or after a longish drive at a steady 3000 or so RPM. Seems to be worse when warm. It's NOT the fuel filter or fuel pump, as these were changed within the last month. Also have new plugs, cap, rotor, and air filter.
I did the EGR cleaning which seemed to make it worse. I'm thinking that I might not have gotten all the gunk out of the pinhole:-0
I'll be redoing that little job this weekend.
Any suggestions as to where to look next? I will also be cleaning out the throttle body and checking other details as per the SE-R FAQ. (As an aside, does anyone know if the gasket for a 91 sentra throttle body will fit the G20? If not, does anyone have the part number for the G20?)
I'll also be rechecking the MAF. I regrounded last year, but what with all the salt and corrosion here in warm and sunny Vermont, who knows....

Thanks in advance,
Dorian
 

·
Registered
Joined
·
705 Posts
Did you try just resetting the idle? Have you messed wiht your timing at all?

------------------
Ryan Walsh, 1997 200sx SE-R w/ ES mounts, JWT s4's, AEBS 4-1, PR CAI, Sportlines/AGX's, Bridgestone re730's, Matrix FSTB, Stillen GTR grill
 
G

·
Discussion Starter · #3 ·
Nope. Haven't messed with idle or timing. Wanted to clean out the EGR and TB before messing around with those, as I've read that the cleaning can cause the idle to need to be reset.

Dorian
 
1 - 3 of 3 Posts
Top