SR20 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Yikes some issues anyone have any idea's?

I get alot of surging and low power in the 2500 to 3000 rpm range and can't figure out the problem.. a dude here in town thought the timing chain may have jumped but I don't hear any wierd noises.. I've replaced the fuel filter, the air filter, the plugs, and have cleaned the egr valve and throttle body.. anyone have any ideas what next.. ohh and I only get 16 mpg ouch.. not good.. o2 sensor maybe??? ummm hmmmm....

thanks in advance...
 

·
Not on fire... yet
Joined
·
591 Posts
sounds like an O2 sensor, but also check your TPS to see if it might be out of spec or just messed up.

------------------
93 NX2K
some stuff and a DET
"project street mod?"
1988 BMW M3 w/ a few toys
 

·
_______
Joined
·
2,170 Posts
Have you regrounded your MAF? That could explain both the hesitation and the poor fuel economy.
 

·
employment whiplash, NC
Joined
·
3,646 Posts
All the above are good advice. I've found the ?BPT? valve (that thing to the left of the EGR valve) gets all cruddy inside. I fixed some rough running in the past by cleaning it with some carb/choke cleaner.

------------------
Matt
92 SE-R from Heck

"What have you DONE to that thing..." - stranger at Rockingham dragway 5/18/01
"Where's the turbo?" - stranger at the 1st autocross of 2000 where my SE-R debuted
"That thing is a goddamn rocket ship. I'm not lifting for you on the straights anymore!" -Karl Shultz, Rockingham 4/27/01
"What in the hell have you done since I drove it last?" -David Stone, Rockingham 4/27/01
 
1 - 7 of 7 Posts
Top