SR20 Forum banner
1 - 7 of 7 Posts

·
yup
Joined
·
1,208 Posts
Discussion Starter · #1 ·
Has anyone ever experienced their ac kicking on and off about every 5 seconds? I know the system is charged cause at times it will stay on and will blow nice and cold. But the majority of the time you can here the compressor kick on for a second and then off for a few. The car is developing a slight whirring whinning noise that is not affected by the ac switch being on or off and doesn't seem to be related to engine speed. it lasts for just a second more than the engine when you cut the engine off. Any idea?
 

·
yup
Joined
·
1,208 Posts
Discussion Starter · #5 · (Edited)
yeah im worried that it is on its way out... is there an easy way to check the clutch on the compressor? also... i had the system recharged in december after i had the jdm swap. During the swap the car had lost its charge (or at least thats what i figured happened since the air wasn't blowing cold.) I wouldn't be surprised though if the dumb mechanic didn't test it and just juiced it up with too much pressure... so ill have to check in to it being over pressurized also... thanks for the responses!
 

·
yup
Joined
·
1,208 Posts
Discussion Starter · #8 ·
dropped the car off at the stealership today... they tried to convince me that they needed to recharge the system in order to diagnos it... i said a big NO... we'll see what happens
 

·
yup
Joined
·
1,208 Posts
Discussion Starter · #9 ·
oh 2nd runner i didn't see your post till now... hopefully that what the dealership tells me... i guess that means that i will be replacing the compressor right?
 

·
yup
Joined
·
1,208 Posts
Discussion Starter · #12 ·
got the car back from the dealership...

They had 4 sets of valves for check r12 cars... none of them worked. They tried to confince my to retrofit my ac to r134a. I said no i dont need to do that. I knew that wasn't the real solution.

Regardless the mechanic said that it is giving all the signs of being over charged. In addition he said in trying to fit the broken valves to check the pressure some of the charge was lost. They said since then it hadn't been displaying the same symptoms.

Now a couple of days later... it has yet to kick on and off. AC blows cold. Compressor might still be getting a little old... it has a small whine. But now my car sounds supercharged ;) Hope this info helps someone in the future. Thanks for the help guys.
 
1 - 7 of 7 Posts
Top