SR20 Forum banner

1 - 4 of 4 Posts

·
www.FAIRTAX.org
Joined
·
8,920 Posts
Discussion Starter · #1 ·
Hi guys, I recently finished up my det swap into a 91 SE-R and wnet to take it on its first drive but the clutch wouldn't disengage. I figured no problem I'll just adjust it. It ended up that I used a 1/4 socket to shim it and even cut threads off of the end so it didn't interfere with the pivot arm but its still not enough! I don't see how the cable could have possibly stretched this much. The clutch is the act xtreme pp and street disc. I have an act hd pp on my NX which I compared for reference and the pivot arm is at less of an angle towards the rear than the SE-R but the clutch is perfect, so I'm not sure what the deal is. Any suggestions?

Thanks,
Matt Ostlund
93NX
91SE-R DET
 

·
They're just cones!
Joined
·
1,941 Posts
Check to see if your pivot arm is broken. That's what happened to mine. What a pain!
 

·
SR20 Enthusiast
Joined
·
480 Posts
there are a few things to check. I also have the same setup. It just wouldn't engage. My pivot arm also points twords the rear than any other clutch I've ever had. Start by replacing the cable. Make sure your parts are thoroughly lubricated. I also broke a clutch lever arm so check that also. If i had to do it all over again. I would either get the hd setup or no act at all. It's given my problems since day 1 and know about 4 others who have had the exact same problem in my area. Let me know what happens, as i'm very intrested to find out what the problem is.
 

·
www.FAIRTAX.org
Joined
·
8,920 Posts
Discussion Starter · #4 ·
I am planning on replacing the cable as my first step. I'm positive the pivot arm is not borken. The pedal feels fine and I havn't even driven the car since I put it back together. It just seems like the pp has a long range of motion before the disc is disengaged.

Matt
 
1 - 4 of 4 Posts
Top