SR20 Forum banner

1 - 4 of 4 Posts

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter #1
I have a 91 classic and it has all ES bushing in the suspension including the power rack..Tokico blues(new)H&R springs and ST swaybars.. I have 16' wheels. I have done the alignment 15+ times myself and I cannot get it to stop pulling. I notice it doesnt pull when coasting but as soon as i give it a little gas it pulls to the drivers side. I have no idea what it could be..camber is -1 deg in front and -1 in rear..toe in rear is 10 deg and front is 10 deg and the caster is 2.1 and right front is 2.9....what is wrong???
 

·
Registered
Joined
·
17 Posts
What kind of home alignment setup do you have?

I've been thining about doing my own alignment too. I was going to try and build my own alignment rack.
 

·
Registered
Joined
·
708 Posts
The car has pretty serious torque steer to the right when you floor it probably due to the LSD. My 92 always wants to pull to the right on acceleration but nothing serious unless I give it WOT.

[This message has been edited by Trys_Hard (edited 07-21-2001).]
 

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter #4
I work at a autobody shop that has the lastest in alignment machines..called the laser 3D...I just have to tap the gas to get it to pull and just cruising down the highway on trips..I catch myself having to hold the wheel to the right to stop it from going off the road..I understand about the torque steering but that does happen even more when i have WOT..
 
1 - 4 of 4 Posts
Top