SR20 Forum banner
1 - 4 of 4 Posts

·
boosting
Joined
·
1,454 Posts
Discussion Starter · #1 ·
I just recently replaced my alternator and now the battery light still comes on very dimly and goes away when I give the car a little gas, any ideas. Thanks.
Sean
 

·
Drive it like ya stole it
Joined
·
6,928 Posts
Try tightening the belt? Check your batter connections, clean them(autoparts stores sell a tool for this specific purpose), make sure you have a good battery....check your alternator connections....I've herd that reman alternators don't work too good on our cars for some reason, your best bet is to get a used one from Andreas Miko....hes on the forums...just look in the forsale/wanted to buy section...hope this helps...

~Ryan
 

·
boosting
Joined
·
1,454 Posts
Discussion Starter · #3 ·
yeah thanks man, the belt doesnt squeel but i havent really been under the car in a while, its to cold out now. Just wondering if anyone heard of that problem before its kinda driving me crazy, especially since all my lights are blown out in my instrument cluster and at night all i see is that dumb light and its not even all the way on its like dim and if i let the idle go real low it gets brighter and higher and it goes away.
Sean
 

·
Registered
Joined
·
329 Posts
Sounds like the alternator is not putting out enough at idle.
This can be caused by several items - shorted stator, open or shorted diode, bad regulator, etc.

When I had to replace the alt in my 1991 SE-R, I priced all the rebuilts. The dealer itself ended up being cheaper and they or course use quality Nissan parts.

Rebuilt parts these days are really crappy from Pep Boys, Autozone, etc etc.
 
1 - 4 of 4 Posts
Top