SR20 Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
I was driving my car in the slush today and all of a sudden the volt light comes on very dimly, and so i figure, alternator must be going or wet belt or something like that...Then I hear a buzzing coming from the dashboard.it happens at lower RPMs and if it sits at idle a bit the brake light comes on. I notice no difference in the petal so my brakes are fine. I'm thinking I have a short in the dash. But what the hell? Thats the strangest thing. Any one else experience this???
 
G

·
Guest
Joined
·
0 Posts
When my alternator was going the Brake like would flicker when I got on the gas.

MarC
 

·
Registered
Joined
·
178 Posts
Discussion Starter #3
Ok, now it stopped doing it. WTF?!! This is very bizarre, but at least it gives me time to save up for an alternator. I have a feeling its warning me before it totally goes out. It looks like it might be a pain in the ass to replace the alternator.
 

·
Registered
Joined
·
77 Posts
When it's pretty cold out, I can notice the headlights, dashboard lights and fan dim/cut a bit when I step on the brakes and let go, and everything comes back when I just tap the gas. I'm a bit worried...

------------------
Nissan, baby, Nissan :D

 

·
Registered
Joined
·
244 Posts
since ive had my car my brake light and battery light have been on. I was told that it was the alternator going out, but when i went to get it replaced for around $225 they said it was just fine. nissans are weird!!!


Daniel
93 NX2000
 

·
Registered
Joined
·
858 Posts
if the light keeps coming on then worry ,remember during the snow you have on the rear def. ,the lights ,heater and radio etc. but if it happens regularly , check it out.my music allways tells me I need more juice . 1st place 500 - 1000 watts class novice first comp. fast but gotta have my tunes!

------------------
91 SE-R,10:1 comp.pistons,balanced &blueprint rebuild.comp.4angle valve job,extrude honed heads/intake manifold,No emissions.crap,RC TB/MAF,nismo cams,UR pulleys,stillen4-1 ceram.header,nismo/centerforce dual fric.clutch,PR CAI,2 1/2 test pipe,mandrel 2 1/4 superturbo ex.,and a whole bunch of other goodies! boost is in the works ,hell yeah 3:16!
 
G

·
Guest
Joined
·
0 Posts
I had the exact same problem when I bought my NX 4 years ago. Turned out to be a leak from the radiator squirting straight onto the alternator. Once it was cleaned out, and the leak fixed, it never happenned again.

Ciao for now!
 

·
Registered
Joined
·
324 Posts
I had the exact same problem when I bought my NX 4 years ago. Turned out to be a leak from the radiator squirting straight onto the alternator. Once it was cleaned out, and the leak fixed, it never happenned again.

Ciao for now!
Looks like what I may have. On the way home today and I got the battery light and could smell a faint smell of anti freeze. Going to look tomorrow to see if the water is low and if there is antifreeze on the alt. Dammit, just picked up an alternator from AZ. Expensive lil bas%ard!!!!

Wish me luck and feel free to post any words of wisdome for the next project.

Thanks all!
 

·
Still not my president
Joined
·
5,173 Posts
old ass thread. however if your battery light and brake light are both on that means your alternator is not working.
 

·
Registered
Joined
·
201 Posts
the buzzing sound is coming from a relay from under the dash and that normilay happens when your altinator has gone out and your battery is almost low this from personal experence
 

·
Registered
Joined
·
324 Posts
OKay,
today, started her up, no radiator leaks detected yet. Going to keep running her to see if it leaks. I'm TOTALLY confused @ this point. Damn, I know it was battery light all the way home last night. I also could smell antifreeze. This is a tough one. Thanks for any feedback you all may have. :)
 

·
Registered
Joined
·
324 Posts
Update / Help needed.
Hey all Here is an update. I went to a local mechanic to have the alternator replaced last year. It was working well up until about a month ago.
What happened is when I would start my car, the batt / antilock / and brake light would stay on. when I would drive it or take the rpm's past 3-4K the lights would shut off and it was business as usual. Well, about 3 weeks of this goes by and it finally got worse. when I reved the engine, the lights would no longer go off. They stayed on and I also noticed the alternator didn't see to be charging the battery.
so I call the mechanic that replaced it since it's still under warranty. So he replaces the old alternator, the old one was no longer charging. However, he tells me that he tested the new one and it's okay BUT the 3 lights are still on and won't go off. I pulled the battery and I'm charging it right now.
Additional notes, the car idles just nicely. I don't get the buzz under the dash and the lights seem to stay strong and bright. I hope that it's just a very low battery. I guess I'll know more in the morning. If anyone has any ideas or been down this road before, please let me know. Thanks in advance.


JoeAngel
 

·
Registered
Joined
·
324 Posts
update:
Battery fully charged, alternator pushing out plenty of power to the car and batt. battery, antilock and brake lights are all still on. :( does anyknow know what else it may be?
note: battery is less than a year old and should be in tip top shape. thanks for any help guys. I'm lost over here.
 

·
Registered
Joined
·
200 Posts
I've got the same problem, alternator is charging, cleaned out all grounds & connections on the alternator, lights still flicker but don't stay on for long, this has been going on for 2 months now, the only thing I can think of is the actual relay under the dash is faulty, but i'm not sure which relay it is, any ideas?
 

·
Registered
Joined
·
324 Posts
That's what mind originally started out like. A new alternator cable took care of that. It was the main plug that goes into the alternator causing the lights to flicker on and off. Now I hear from the dealership that the alternator is actually over charging. GRRRR!
 

·
Registered
Joined
·
200 Posts
I've changed the plug aswell but nothing, maybe your belt is on too tight, that would cause it to overcharge, there should be a bit of slack in the belt.
 

·
Registered
Joined
·
324 Posts
New Cable solved the flickering Batt, Antilock and Brake lights

New alternator fixed the overcharging issue.

CURSE THAT @#%#$%#$ ALTERNATOR!!!!!!
So originally 400 at mechanic to do the alternator in the dead of winter... worked okay for a few months then the replacement alt died. After that he replaces it under warranty with an overcharging bastard alternator.
Nissan and Fluke said, that alternator was overcharging...
autozone sold me a new alternator and after some bumps, scrapes, cursing at the tight alternator area, we are not 100% electrical issue FREE~!!!!!!!

AGH!!!!!!
 
1 - 18 of 18 Posts
Top