SR20 Forum banner
1 - 17 of 17 Posts

·
I look good going slow
Joined
·
1,161 Posts
Discussion Starter · #1 ·
Bluebird u13 swap
SAFC w/p10 stock ecu
2.5 dp straight pipe to muffler
Autometer boost gauge(solid 7psi)
Vacuum at idle (16)
Stock fuel pump
No ecu codes

Well, my car backfires between shifts and feels really underpowered. Im wondering what should I check to make sure everything is running alright. I think my timing is way off but no shops in this damn city even carry inductive timing lights anymore.
 

·
Wants Primera Race Motor
Joined
·
2,390 Posts
well u still have the stock Fuelpump, but it could be from running rich?
also if you have no cat it can backfire
 

·
Registered
Joined
·
909 Posts
sounds (and probably smells) rich. check your 02 voltages (if thats what you are using to tune with) and see how rich things are. i noticed with my safc i was able to determinate how much throttle it takes to hit boost and i set that percentage for the low throttle. my low throttle map is pretty lean and helped stop the backfire. at WOT its different through. if you backfire from running too rich there then you might just have to deal with it.
 

·
Banned
Joined
·
1,167 Posts
Its deffinatley bound to happen from time to time, It started happening when I took my cat out, Now im running a staright pipe, But i get no loss of power between shiftes, It just pops, even throws fire sometimes.
 

·
Stuck on an island
Joined
·
1,284 Posts
back fire can be caused from exhuast leaks too, or running lean but that sounds more on the poping side
 

·
I look good going slow
Joined
·
1,161 Posts
Discussion Starter · #14 ·
I have my recirc valve recirculated. Im also guessing that my timing might be off because until boost hits around 2500rpm my car is a slug. Possibly too rich with the afc but low throttle avg is -17% hi throttle avg is -10%
 
1 - 17 of 17 Posts
Top