SR20 Forum banner

1 - 6 of 6 Posts

·
XE-R Overweight
Joined
·
125 Posts
Discussion Starter #1
I have been running SUPER rich since I got the car running again after the swap. Well I finally tested the Injectors and got a wierd reading. Basically the reason why I feel the injectors are to blame is I get about 120 miles to the tank since the swap, and when Im at cruising speed the car holds back alot, like it suddenly is running on three cylinders. This thing backfires like a mofo too. Well heres the readings I got testing the resistance...

2k OHM

.028
.011
.017
.011

Arent all three supposed to be at like 9-12? I cant seem to find what Im looking for in the archives yet, any help on this would be much appreciated

------------------

AIM = AZSentraXER
 

·
now on the West side!
Joined
·
3,661 Posts
if my Haynes manual holds any validity, injector resistance should be 10-14 ohms...

i'll check my FSM when i get home tonight, hope this helps

-C-
 

·
P10 Geek
Joined
·
1,565 Posts
AZSentraXER said:
Well heres the readings I got testing the resistance...

2k OHM

.028
.011
.017
.011
I would say you have a bad injector. Easy DIY backyard test is to start the car and while it is running, pull the wire to the spark plug where you got the .028 reading. If the car still runs without any change, that injector is bad and needs replaced. If the car runs worse, they injector is ok.

This is not a proven technique, just one that has worked for me a few other SR20 owners who ran into the same problem. All three of them also had a bad injector, replaced it and vroom! Back into business.
 

·
XE-R Overweight
Joined
·
125 Posts
Discussion Starter #5
If the car runs worse, they injector is ok.
Well when I pull one out, it runs bad... it does this on all four though. Like I was saying, its just running super rich. I dropped the car off at the mechanics with a list of stuff. Before I left, he showed my this instrument that tests the resistance, and you select the engine your working with, and it will tell you what recommended settings are. That instrument showed 10-15 for a 1991 SR20DE. He was a little surprised too, like I was, that the reading was high, normally when the injectors go bad, its lower. Not really sure why this happened but it did.

At least the injectors are easy to get to on this engine. My GA16DE that was in it before, had the Intake Manifold above the injectors making it a bitch to get out.

Whats really funny... I drove the car up to Mount Lemmon (~8000 feet) from Tucson (~2500 feet), and the car only felt better the higher we went up. It was wierd. Of course when the Coil Wire popped out, and flames were shooting out the muffler, I sure scared alot of people, including me LMAO.
 

·
Low flying black object
Joined
·
669 Posts
and flames were shooting out the muffler, I sure scared alot of people, including me LMAO.
Is anyone picturing Cartman from Southpark right now...? "ah di not have sex wit an ALIEN..!" poooooof! :D
 
1 - 6 of 6 Posts
Top