SR20 Forum banner
1 - 10 of 10 Posts

·
pimpin since 03!
Joined
·
1,348 Posts
Discussion Starter · #1 ·
i have what you see in my sig and, at this moment still am working out some bugs... but i have read alot of places that the t25 is boosting at like 3k... well mine is the ballbearing so i would think it could maybe be even a little lower than that... but mine doesnt seem to be the same?? it makes ok power all the way to about 3.8k and then right at 4k it kicks me in the back hard... is this normal for the bb t25 or should i bee feeling boost alot earlier??? if so whats causing this?
 

·
pimpin since 03!
Joined
·
1,348 Posts
Discussion Starter · #2 ·
lol ill follow up on my own thread.! i went to a local shop to talk to a guy that knows alot bout turbo charging and he said that my turbo is spooolling way tooo late! he said that its most likly because i am running my greddy profec and it is not tuned properrly yet.
 

·
Tired!
Joined
·
10,149 Posts
guaranteed it is the profec spec II not setup up properly. Travis posed how he set his with good results, but very VERY few have had any type of success using it.

Brent
 

·
pimpin since 03!
Joined
·
1,348 Posts
Discussion Starter · #4 ·
well i unpluged it... and i ran the pressure source of my cold side of the pipes to the actuator(wg) and it still seems to be at the same point... i feel boost some what being made around 2.5k but it is totallyy hitting at 4k.... whats going on ... by some chance is that the wrong place to run the pressure off... or do i have a leak and its just taking that much rpm to make it boost???
 

·
Registered
Joined
·
3,442 Posts
I think pinning u in the seat at 3k is early enough
 

·
pimpin since 03!
Joined
·
1,348 Posts
Discussion Starter · #10 · (Edited)
ok thats good, i just wasnt sure because i was talking to someone about the ballbearing t25, and he said it shouldnt even feel like it lags at all....
 
1 - 10 of 10 Posts
Top