SR20 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
722 Posts
Discussion Starter · #1 ·
Well I finally get the damn thing running and now this ..

I haven't had a chance to really get out and look at what's wrong since I'm at work (and i'll be darned if I work on my car in these clothes :p. Smoke looked to be a fairly thick white color. Didn't look to be blueish in any sense. Every time I would shift or give it a little gas and let off (and sometimes while accelerating) this white 'smoke' would come out and literally just sit over the middle of the road. I did get out of the car and smell some of the exhaust fumes, it smelled overly rich (like usual) and had a slight burning smell to it. I'm not sure what burning oil smells like because I've never had that problem. So I pulled over real quick, took the dipstick out, saw that I had plenty of oil, glanced around the engine bay, listened, smelled, and then drove off. It's hard to decipher the different smells coming from the exhaust fumes since I'm running so rich right now.

What could this be? My headgasket blown? I checked my coolant levels and they are fine and the coolant doesn't seem to be mixed w/ oil (although I only checked the rad), and I checked my oil and it isn't milky in any way, just black (200 miles on a swap, time for change, hehe). This stuff is like heavy. I can accelerate, go about 30 yards, look back, and still see it hanging over the road.

If this is my head gasket it looks like i'm in for a bitch of a weekend. :-\
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #2 ·
Okay well after talking to a few people about this and giving them the symptoms their diagnosis is that it is the turbo going byebye, but I am going to pressure test the coolant lines, check the plugs, etc. before jumping to that conclusion. If anyone has any further advice feel free to chime in. Thanks!
 

·
Registered
Joined
·
1,317 Posts
pdr said:
Okay well after talking to a few people about this and giving them the symptoms their diagnosis is that it is the turbo going byebye, but I am going to pressure test the coolant lines, check the plugs, etc. before jumping to that conclusion. If anyone has any further advice feel free to chime in. Thanks!
Mine was doing the same thing.....turbo seals going bad. Look to see if you have any oil leaking from around the housings of the turbo, or any oil in the compressor housing.
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #4 ·
Okay .. when this starts happening, how long do I have before the entire unit craps out?
 

·
Rebuilding the W11:P
Joined
·
1,114 Posts
You can never really tell how long. Just swap/rebuild when you have the $.
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #6 ·
Well the car no longer runs. Idles like ass and I can't even rev the motor. Oil was also dripping from the muffler.

Last question .. I have a U13 motor, will the U12 T25 work? I'm honestly not sure if the U13 and U12 manifolds are different. Sorry for the noob question.

thanks
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #8 ·
IIRC, the compressor on teh U13 T25 is rotated differently than the U12, correct? My hot side i/c piping has to run underneath the car, and not over like everyone w/ the U12.

Hell if the turbo isn't too shot I'm just going to put T28 internals in.
 

·
The Anal Rententive Tuner
Joined
·
244 Posts
pdr said:
Oil was also dripping from the muffler.
you have a really nice oil leak. most likely the turbo oil seals or rear main seal. when you swap in a det you should always swap the rms and the water pump for new units.
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #11 ·
Yeah that's usually a habit of mine when I've done some swaps on Hondas, but when it comes to my car I guess it's okay to cut corners. :tongue:

Well my alternator is dead, that's why I couldn't rev the motor, etc. It's really hard to diagnose things in a suit while you're on your way to work. haha

Anyway took the turbo off last night and there is basically no play in the shaft. Should be rebuildable no problem. Lotsa oil, though. I'm glad I have Earl's braided lines to put back on b/c those banjo bolts will be a PITA to tighten. Well, not really a pita just time consuming.

What's the general price for a T28 internals upgrade? I talked to one place (Majestic Turbo) and they said about $450, but they were unsure.

thanks again all
 
1 - 11 of 11 Posts
Top