SR20 Forum banner
1 - 10 of 10 Posts

·
Revolutionary
Joined
·
830 Posts
Discussion Starter · #1 ·
I got a b14 put a kenwood cd player in it about a month ago after the other one that was in it died. The other day it just cut out, the cd player kept counting like the cd was still playing and the tuner would display but no sound from anything. Today when I got in the car it wouldn't even light up. Has this happened to anyone else, what is going on. Thanks
 

·
Registered
Joined
·
324 Posts
What Model?
What speakers / or amps were you using with it?
When installed, what did you use to make speaker connections? Butt caps, tape, etc?
Where was the battery wire connected to? The factory wire harness or elsewhere? If Harness, check the fuse block to rule that out.
Does it have an inline fuse on the back Battery wire? if so, have you checked that?
How old is the unit and where did ya get it?
When it stopped playin, did the tuner produce sound or did it just light up like the cd player?
 

·
Revolutionary
Joined
·
830 Posts
Discussion Starter · #3 ·
It's just hooked into the factory wiring, I didn't want anything fancy I just wanted to be able to listen to cd's. Factory speakers, used butt connectors, I didn't check thefuse block yet but I would imagine that the whole thing would have cut off right away if the fuse blew , right, I just bought it at Best Buy at the begining of September, the tuner just lit up no sound, I also want to add it felt a little warm when I taouched the bottom of it, I don't know if thats normal or what this is not my area of expertise. Thanks
 

·
Registered
Joined
·
324 Posts
If it's that new hopefully best buy will replace it. From what you've told me, it sounds like something in the "power management" part of the radio died. This probably would have cause the output parts of the radio to die first followed by the rest of it.
If best buy won't let you return it, let me know and I can make a few suggestments. Good luck....
 

·
VVL SE-R
Joined
·
220 Posts
Josht34237 said:
It's just hooked into the factory wiring, I didn't want anything fancy I just wanted to be able to listen to cd's. Factory speakers, used butt connectors, I didn't check thefuse block yet but I would imagine that the whole thing would have cut off right away if the fuse blew , right, I just bought it at Best Buy at the begining of September, the tuner just lit up no sound, I also want to add it felt a little warm when I taouched the bottom of it, I don't know if thats normal or what this is not my area of expertise. Thanks
did you ground the radio seperatly from the factory harness? nissans dont have a ground in the harness, if you follow the wire back from the after market harness to the factory harness nothing comes out the other side. trying to ground threw the case is not enough for most after market radios. anyway if you didnt allready try running your own ground. and if you did replace the radio!
 

·
Revolutionary
Joined
·
830 Posts
Discussion Starter · #7 ·
ok I regrounded it from off from the harness, it worked for 3 songs then cut off again, I'm going to try grounding it some where else and see if it works like that
 

·
Revolutionary
Joined
·
830 Posts
Discussion Starter · #8 ·
I grounded it to a the streering column and it worked for a little while then cut off. So I put the new harness that came with the radio in the car, I had just been using the old one since it was the same thing. Now it works for a few hours but will cut off if the volume is up too high. It started to cut off once and I turn the volume all the way down and it stayed on. Also one of the rear speakers is trashed can barely hear anything out of it even with the volume way up. I don't know if that could be contributing to my radio woes or not but I thought I'd throw it in there.
 

·
Revolutionary
Joined
·
830 Posts
Discussion Starter · #10 ·
well the wiring was pretty hacked by the previous owner but I tryed cleaning it up a bit, now after I replaced the harness and regrounded it stays on for a while longer, I'd say I probroly get around 15 hours of play out of it before it cuts out, unless the volume gets turned up all the way or almost all the way it will almost always cut off immediately.
 
1 - 10 of 10 Posts
Top