SR20 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
244 Posts
Discussion Starter #1
I went down to shucks and bought the socket made for it, 15 bucks, what a rip off!!!
any tips from you guys to help me make it any easier?

------------------
Daniel K
93 NX2000 w/ intake and more to come!!!!!
 

·
employment whiplash, NC
Joined
·
3,646 Posts
Remove a few of those stupid emmisions things from the front of the engine, and take out both radiator fans.

Sounds like alot, but takes about 10 minutes.

Matt
 
G

·
Guest
Joined
·
0 Posts
All I did, was wait for the motor to cool, and then shot a little WD40 around the sensor to loosen it. Make sure you clean up the residue, though; O2 sensors don't like WD40 too much. I found that I could remove it just with the socket, and not having to take all that crap off the car-It took me less than 10 minutes to do the install. The only thing I f**ked up was the place where the female connector mounts near the AIV got partially snapped off because it was rusted on there pretty good.
 

·
Registered
Joined
·
244 Posts
Discussion Starter #4
how do you take off the fan, how many bolts are there, Im not too good with taking things apart and having to put them back together. I thought it was going to be a lot easier, I unplugged the sensor and cut the wire to get it out of the way, now a friend told me at work that it is easier to take it out if the engine is warm. can i still start it and let it run if the sensor is not hooked up and is a little mangled from the vise grips from try #1? I cant get the socket over the bolt head until i take out the fan, not enough clearence.

------------------
Daniel K
93 NX2000 w/ intake and more to come!!!!!
 
1 - 4 of 4 Posts
Top