SR20 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,160 Posts
Discussion Starter #1
Ive noticed in my se-r and my brothers se-r (the blue one) that out clocks always go back to showing 12:00 after you shut the car off. Does anyone else have the problem? Is there a way to fix it? We have also had problems with out dome lights not working... my brother just replaced his bulb, but it still doesnt work? Could it be something with the fuses? Thanks
 

·
/// God Speed! ///
Joined
·
1,917 Posts
sr20sentra91 said:
Ive noticed in my se-r and my brothers se-r (the blue one) that out clocks always go back to showing 12:00 after you shut the car off. Does anyone else have the problem? Is there a way to fix it? We have also had problems with out dome lights not working... my brother just replaced his bulb, but it still doesnt work? Could it be something with the fuses? Thanks
The clock should have a dedicated power source that powers it up all the time.
Sounds like that source is being broken somewhere. If I had a wiring diagram I could tell you what fuse to check and which wires.
There again the dome light should have a constant power source to get voltage any time it needs it. I am wandering if both are powered off of the same fuse?
 

·
Registered
Joined
·
1,160 Posts
Discussion Starter #3
i have the wireing diagram and everything for the car, so your saying its something with the wiring or maybe something with the fuses, huh. hmm.
 

·
/// God Speed! ///
Joined
·
1,917 Posts
sr20sentra91 said:
i have the wireing diagram and everything for the car, so your saying its something with the wiring or maybe something with the fuses, huh. hmm.
First off you need to know what fuse or fuses the dome light and clock operate off of. Check the fuse or fuses, if OK look at the wires.
I bet you have a fuse problem though.
 
1 - 5 of 5 Posts
Top