SR20 Forum banner

1 - 4 of 4 Posts

·
84.7 hp
Joined
·
369 Posts
Discussion Starter · #1 ·
i have a 93 sentra se-r, when the engine is cold it has a hesitation that almost feels like the throttle body is sticking closed. When i drive it there is a point that you can feel during throttle application, where i get almost nothing, then
at around 2,500 to 3,000 rpms it seems to buck almost violently, the car stops
doing it once the temperature needle gets about halfway to normal operating temp. anyone have any idea what this could be? have changed plugs,wires and
and looked for vacuum leaks already, i run 93 octane gas,( if that helps anybody)

thanks,
 

·
Registered
Joined
·
947 Posts
I have the same issue, and I think I have narrowed it down to the Idle Air Regulator. If you do a search, you'll find many different posts on what to do. You can also check se-r.net.
 

·
Premium Member
Joined
·
9,405 Posts
Here's a question, what ECU are you using? What are your mods? This seems to be an issue with JWT ECUs using bigger than stock injectors. My old ECU didn't do this, until I got the VE program. In my case, timing was being pulled out between 2,000 and 2,500.
 

·
I lika da turns
Joined
·
710 Posts
eric96ser said:
Here's a question, what ECU are you using? What are your mods? This seems to be an issue with JWT ECUs using bigger than stock injectors. My old ECU didn't do this, until I got the VE program. In my case, timing was being pulled out between 2,000 and 2,500.
What do you mean your "...timing was being pulled..."? I have this same problem at those rpm's but I have a Classic California-model (in my non California car) ECU. Do you think this makes a difference?
 
1 - 4 of 4 Posts
Top