SR20 Forum banner

1 - 7 of 7 Posts

·
all sentras r slow!
Joined
·
187 Posts
Discussion Starter #1
Here is the problem. It seems as if all four of my crossmember bolts are too long. They all screw in about 85% of the way and then feel as if they're bucking on the frame. As a result of this, the crossmember itself isn’t sitting flush with the chassis in the front or rear. When I back in & off the gas I hear a lot of clunking around, because the crossmember is screwed up all the way. What do I do? The only thing I can think of is getting shorter bolts.
 

·
Registered
Joined
·
645 Posts
I just did a swap and cross threaded 2 of my 4 crossmember bolts. :thumbsdown:
 

·
Registered
Joined
·
753 Posts
Do you have the rubber spacers installed in your crossmember? Each bolt should run through a rubber bushing/isolator.
 

·
all sentras r slow!
Joined
·
187 Posts
Discussion Starter #4
I have the rubber spacers up front and not in the back. Even with the spacers in the front, the crossmeber still does not sit flush up front. Do you think if i install the spacers in the rear, it will solve my problem in the front and rear?
 

·
Registered
Joined
·
417 Posts
same here but i stripped the treads, would any one recommend welding the crossmember up on the body?
 

·
B13 se-r
Joined
·
259 Posts
well dont weld the crossmember up to the body, thats pretty retarded!!! but just get like a big nut that will fit over the bold. use it as a spacer and tighten it up. that should work. one of my friends had to do that same thing..i havent done it to mine cuz 2 of my 4 bots are stripped and i have to retap them! which sucks ass!
 

·
Registered
Joined
·
417 Posts
ok i want to retap it, but could i use regualar bolts, cuz the stock ones are small i guess
 
1 - 7 of 7 Posts
Top