SR20 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4,673 Posts
Discussion Starter #1
On Wed I installed my AEM CAI. Everything is fine except my idle is a little bit rough now. It is only when its cold. Once my car heats up its no problem. When I put the clutch in and am stopping at a stop sign, I can see my rpm's dropping pretty low and the engine starts to stutter, then it finally goes up some. Again, that only happens when the engine is cold. Has anyone else had this problem? My car is otherwise stock.
 

·
Registered
Joined
·
441 Posts
How is the AEM CAI what do you think? loud roar at WOT? hissing sounds at idle? tell us your thoughts
 

·
Registered
Joined
·
4,673 Posts
Discussion Starter #3
I like the intake but I dont really have anything to compare it too. The one down side is that it requires you to cut the battery tray and the fender wear the lower resonator is. It sounds pretty much the same at idle, but it makes a really cool roar at WOT.
 

·
Baby Blue VVL
Joined
·
3,202 Posts
my PR CAI sounds better than my stocker at idle

O

------------------
4 door SE-R
Ultimate Sleeper
I love the CAI
I Got Money for a little more, suggestions needed
"heavy weight and still undisputed!"
 

·
egg-less
Joined
·
348 Posts
Hey mpg9999, mine does EXACTLY the same thing. Only problem is, I've had my CAI for a year and a half, and this idle problem only started two months ago, after I had the clutch replaced. I think the idiot mechanic ****ed something up (I KNOW he ****ed up at least 3 things that have since been fixed). I've had my car to Rosen Autosport, a very knowledgable SR20 shop, and they can't figure it out either. No bad engine codes, either. If you find out anything, please let me know.
 

·
Registered
Joined
·
174 Posts
If you have relocated the battery to the trunk and removed the battery tray would it create any installation/mounting difficulties? Did you have to cut/widen any sheet metal?

------------------
93 SE-R JWT S3 Cams, JWT ECU, JWT Pop-Charger, HS Header,RT Cat, HKS exhaust, Hypercoils, KYB-AGX, ST Sways, N-Tech Brace, Stillen STB, SMC SS.
 

·
Registered
Joined
·
4,673 Posts
Discussion Starter #7
I wouldnt think that having the battery relocated would cause any problems. The intake comes with some battery relocation things that move the battery tray an inch or two towards the engine so that the intake pipe has room. You do have to cut sheet metal. You have to cut a little bit from the battery tray, which I would assume you wouldnt have to if you have a relocated battery. You also have to cut a hole where the lower resonator is. I will post pics in a day or two of the hole and the installation so you can see what im talking about. BTW, aknapp, why would the mechanic be anywhere near the intake or even the engine when replacing the clutch, shouldnt he only be doing stuff to the tranny?
 

·
Registered
Joined
·
174 Posts
MPG,

Did you reset the ECU? Even if you did it sometimes takes awhile to "re-learn" the new A/F alpha.
 

·
Registered
Joined
·
194 Posts
check and see if ALL your intake clamps and connections are on tight. Most mass air cars will do that when some hoses are loose b/c incoming air is not entering throught the sensor and screws with the ECU with air/fuel mixture etc....
 

·
Registered
Joined
·
4,673 Posts
Discussion Starter #10
I checked the hoses tonight, and they appeared to be on tight, but I will check again tommorow in the light. Maybe its the ecu, because I dont know what reseting it is? How do I reset it?
 

·
Registered
Joined
·
727 Posts
Usually on every car I have owned before, all you do is disconnect the negative battery terminal for about 15-20 minutes then reattch it and drive.

------------------
95 200SX SE-R--> Hot Shot CAI, Custom Apexi Cat Back, ST Shifter & G4 Hotshot Headers, Viteks and Iridium, B&G springs, 17" Konig Tantrums wrapped in Nitto's, a bunch of stiffening and look good crap, 91 Cams, JWT CPU COMING SOON!
 

·
Registered
Joined
·
1,147 Posts
you might also want to advance your timing. it'll help your idle and give a small hp gain. it helped me when my idle did the same thing, only it happened when the A/C was on recirculate.
 
1 - 13 of 13 Posts
Top