SR20 Forum banner

1 - 12 of 12 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
hey, this might take a minute--
first off, the problem is on my 91 g20.
whenever i'm in say, 4th gear and downshift to3rd and speed back up again(not racing, just regular driving) my engine surges, not bad, but i can feel the loss of power, the engine's just not acting right.
Anyway, 2 things i have done might have
****ed it up.....1. I cleaned the spark plug
wires a while ago, maybe i didn't get all the soap off or something?
2.- I took off the BPT valve (to fix the
"ERG Problem" as mentioned on sr20.net) and discovered the tube that's connected to the bottom of the bpt valve had a big hole in it. Now who knows
how long i'd been driving it like that....
I took it off and drove it about 20 miles to the shop. could that have messed it up worse?

So now I got a new tube, and instead of fixing things, it got worse. At least it
doesn't cut off anymore when i come to a stop though!

can anybody make some sense out of this??
any suggestions as to what it is and what i
should do?
later
ricardo
 

·
Registered
Joined
·
858 Posts
check the usual.clean TB, check or replace all vaccum lines (rubber).timing etc.cap and rotor

------------------
91 SE-R,10:1 comp.pistons,balanced &blueprint rebuild.comp.4angle valve job,extrude honed heads/intake manifold,No emissions.crap,RC TB/MAF,nismo cams,UR pulleys,stillen4-1 ceram.header,nismo/centerforce dual fric.clutch,PR CAI with POPchgr,2 1/2 test pipe,mandrel 2 1/4 superturbo ex., ZEX flywheel & JW 50 shot nos with 60 shot jet. and much more goodies!
 

·
Registered
Joined
·
415 Posts
How many miles do you have on your clutch?

------------------
1993 Nissan Sentra SE-R (5-Speed Manual)
STILLEN Hi-Flow Intake System
STILLEN Performance Exhaust System
15x7 Kosei K1 Silver Racing Wheels
195/50 ZR 15 Dunlop SP Sport 5000 Tires

[This message has been edited by Chris93SER (edited 07-12-2001).]
 

·
Registered
Joined
·
415 Posts
Somerset County. A small town next to Somerville and Bridgewater.

<font face="Verdana, Arial" size="2">Originally posted by jayac:
This is off topic, but Chris93SER, where in NJ are you from??

-jason

</font>

------------------
1993 Nissan Sentra SE-R (5-Speed Manual)
STILLEN Hi-Flow Intake System
STILLEN Performance Exhaust System
15x7 Kosei K1 Silver Racing Wheels
195/50 ZR 15 Dunlop SP Sport 5000 Tires
 

·
Registered
Joined
·
415 Posts
Somerset County. A small town next to Somerville and Bridgewater.

<font face="Verdana, Arial" size="2">Originally posted by jayac:
This is off topic, but Chris93SER, where in NJ are you from??

-jason

</font>

------------------
1993 Nissan Sentra SE-R (5-Speed Manual)
STILLEN Hi-Flow Intake System
STILLEN Performance Exhaust System
15x7 Kosei K1 Silver Racing Wheels
195/50 ZR 15 Dunlop SP Sport 5000 Tires
 
9

·
Guest
Joined
·
0 Posts
Discussion Starter #7
My EGR and BPT are disconnected and my engine runs fine. Hmmmmmm..........
Maybe theres water in the wires?
I hope you didnt soak'em in a bucket.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Hey i'm new to this forum, but i am having that same problem. I get a surge between 2-3 grand. It doesn't seem to matter what gear i am in. My car has also stalled on the freeway going at freeway speeds (55-60 mph; 2750-3000 rpm). I am beginning to think that this is a fuel problem. Maybe the fuel pump...i dunno. I was wondering if anyone else has this problem. I was thinking of changing my fuel pump next week.

BTW
i have a 93 sentra se-r,exhaust, intake, ignition, bypassed the egr(and a lot of the emmisions stuff for that matter). I have not regrounded the mas yet. i get about 27mpg mostly city. anything else you need to know?
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #10
yo Chris93SER- I replaced my clutch about 2 yrs ago,
i'm not sure exactly how many miles, maybe
26,000??
--redman- what is the "TB" & "timing etc"
--94_REDSE-R---nah, i didn't soak em in water, i just wiped em off a bit.
---silversx--- what & where is the ECU &
how do i reset it??
--nismo go to http://www.sr20de.net/ and look
under "problems" i think, that is where i
got a little info about the surges. They
call it "the infamous ERG problem"

a yo, i don't really know a whole lot about
cars, i'm just tryin' to save some money!
anyway thanks for all the replies.
ricardo
 

·
Registered
Joined
·
415 Posts
Alright, then it's definitely not you clutch slipping, unless you REALLY abused that clutch for 26,000 miles. I had a similar problem with the RPM surging, but it was due to my clutch slipping. I had 82,000 miles on my clutch though. I've got about 3,000 miles on my new clutch.

<font face="Verdana, Arial" size="2">Originally posted by rico_law78:
yo Chris93SER- I replaced my clutch about 2 yrs ago,
i'm not sure exactly how many miles, maybe
26,000??
</font>
[This message has been edited by Chris93SER (edited 07-13-2001).]
 
1 - 12 of 12 Posts
Top