SR20 Forum banner

1 - 6 of 6 Posts

·
AWD owns me
Joined
·
4,167 Posts
Discussion Starter · #1 ·
OK i got all of the mounts just to be safe. The rear and the tranny are just inserts, but the front and passenger you have to press. I already pressed the front one, (fun). What do i take out of the passenger side one? The Just the rubber, or the ring around it too? I can already tell this is going to be fun too.

------------------
93 SE-R with 91 SR20DE. When you're driving an SE-R, you're living. Everything else is just waiting.

Thinkin of suspension....
 

·
pwnd
Joined
·
3,455 Posts
Well the front one does have to be pressed in. As for if that ring goes with the new mount or not...thats been left up to discussion. I dont remember which way people recomend.
 

·
AWD owns me
Joined
·
4,167 Posts
Discussion Starter · #3 ·
Did em today, you do have to take it out, the ring and all. Definetly need press
 

·
AWD owns me
Joined
·
4,167 Posts
Discussion Starter · #5 ·
yeah i have a garage, but it's for cars. I have tools but have access to a couple shops. Why what do you need done?
 

·
AWD owns me
Joined
·
4,167 Posts
Discussion Starter · #6 ·
OK I have the ES motor mounts. On the directions it says to use big washers for the inserts. It doesn't even come with the damn things! And the hole for the mount is offset too. Anyone have any ideas on what to use????

------------------
93 SE-R with 91 SR20DE. When you're driving an SE-R, you're living. Everything else is just waiting.

Thinkin of suspension....
 
1 - 6 of 6 Posts
Top