SR20 Forum banner

1 - 14 of 14 Posts

·
www.motorists.org
Joined
·
3,047 Posts
Discussion Starter #1
Since I got the Courtesy exhaust my car has done this. Any turbo SR20 powered car with a decent exhaust that I've heard of does this. Why? Is it because the JWT ECU runs so rich? What negative effects can this have? Can't it hurt your cat if it's exploding in there? Having combustion in other places that it should happen just doesn't sound at all good to me.

------------------
Ben98SentraSE
98 Sentra SE TURBO
 

·
former pulsar car whore
Joined
·
1,397 Posts
Yea, lack of back pressure sounds right too. That's probably it since I've got 2.5" piping.

------------------
Ryan 97 Black SER
advanced timing,custom 2.5" catback exhaust with dynomax super turbo muffler, Unorthodox Racing Pulleys, ES shifter Bushing, Hotshot Header(not installed), Hotshot CAI (to be installed after I return from Canada)
 

·
former pulsar car whore
Joined
·
1,397 Posts
Ben when I first got my exhaust my car did the same thing. It doesn't do it anymore, so maybe the ECU just has to learn the mod?

------------------
Ryan 97 Black SER
advanced timing,custom 2.5" catback exhaust with dynomax super turbo muffler, Unorthodox Racing Pulleys, ES shifter Bushing, Hotshot Header(not installed), Hotshot CAI (to be installed after I return from Canada)
 

·
Enemy of the stupid
Joined
·
4,727 Posts
My friends SE-R poped alot when he was slowing down. Then we pulled the fuel rail off..... The Orings on the 370's were ucked up. "Why didnt you change them the 1st time?" ...... Lazy people do lazy things
we changed that an it didn't pop as much. Then he put the 3" cat on an it didn't pop any more.

------------------

Do you smell what the talon is cooking?
 

·
www.motorists.org
Joined
·
3,047 Posts
Discussion Starter #6
Well I don't get any popping besides during shifts under a gerenous amount of acceleration. Slowing down or whatever doesn't pop whatsoever. Ben Moses's DET with 2.5" exhaust does the same thing actually.

Any more ideas? I did change my o-rings with the injectors, but again I don't have the symptoms that Yellow4g63 mentioned anyways.
 

·
Get Some!!
Joined
·
596 Posts
man, my car always backfires on deceleration. It's done it ever since I took the CAT out.
 

·
Registered
Joined
·
496 Posts
Yup...got the pops too. I have the Courtesy Exhaust Gen 3 header...!

George P.
 

·
_______
Joined
·
3,640 Posts
Pops all around with mine. A bit of fire here and their too. I have a pin hole leak on one of my IC pipes so untill I get that fixed thats what I'm blaming it on.

Mike
 

·
Side by side through 9
Joined
·
719 Posts
My car has the JWT Turbo ECU, 370cc injectors, (the turbo is out right now), and she pops like a race car on decelleration. Josh from SCC was in my car on the track in Vegas 2 weeks ago and loved the sound :)

Tom
 

·
Registered
Joined
·
705 Posts
Ben, it did it on my car too, before i sold it you. It is simply the loss of backpressure through 2.5" pipes, nothing to worry about!

------------------
Ryan Walsh, 1997 200sx SE-R w/ ES mounts, JWT s4's, AEBS 4-1, PR CAI, Sportlines/AGX's, Bridgestone re730's, Stillen GTR grill
 

·
Premium Member
Joined
·
5,202 Posts
<font face="Verdana, Arial" size="2">Originally posted by Ben98SentraSE:
Since I got the Courtesy exhaust my car has done this. Any turbo SR20 powered car with a decent exhaust that I've heard of does this. Why? Is it because the JWT ECU runs so rich? What negative effects can this have? Can't it hurt your cat if it's exploding in there? Having combustion in other places that it should happen just doesn't sound at all good to me.

</font>
A lot of the time, it's because of an exhaust leak somewhere.

Mike
 

·
NX2K Junkie
Joined
·
448 Posts
Mine pops and all I have is an intake and a muffler with stock piping.

------------------
Greg Taylor
96 SE-R w/ stuff
My Page
 
1 - 14 of 14 Posts
Top