SR20 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
850 Posts
Discussion Starter · #1 ·
I had my car emission tested today and as you can see it failed badly. Now according to my techtom the o2 is toggling more than 5 times in 10 sec. I'm pretty sure my air filter might be dirty I haven't cleaned it in forever. Also I noticed I'm running alot of O2% compared to other tests and other cars. Even the dilution which I think is A/F ratio is super rich. The last test I took and failed showed 14.8 and 14.4 respectively.

So the car is running very rich in closed loop however the ecu's A/F alpha is between 96-104%. Since my mdm-100 is in graph mode I was able to look at the o2 volt during a WOT 2-3 gear run, it made 0.84-0.86v. The maf logged 4.64v max along with 14.0 msec at 7400rpm. Now I've ordered an OBD II compliant cat from summit that is 2.5in in the hope that it will allow my car to pass.

 

·
Bitter Old Man
Joined
·
2,623 Posts
Since both the HCs and NOx are over, I'd replace the cat.
 

·
Registered
Joined
·
591 Posts
time out, check yout timing.... if u had previously advanced it, you might wanna put it back to where it was originally, i did that when i 1st got my NX cause i failed b 4 points, anyways, it cut those numbers in HALF!!!! like butta
 

·
Registered
Joined
·
1,591 Posts
this might seem trivial, but I failed 3 times because my cap and rotor were bad. it can't hurt, so check those.
 

·
Its modding time
Joined
·
79 Posts
Ya, sorry to hear that, it must suck living in those states with emissions, ;-) Luckily im in Indy so i dont have those problems, Anyway goodluck
 
1 - 7 of 7 Posts
Top