SR20 Forum banner

1 - 8 of 8 Posts

·
SR powered S13 coupe
Joined
·
6,728 Posts
Discussion Starter · #1 ·
Well I have finally turboed my car. I had a few problems, most of them related to the vacuum line to my BOV & boost gauge, and still have a few to fix.



I still need to repaint the intercooler piping, add a scoop, and fix the small oil leak off the back of my Nissport adapter. Besides the few problems, the install went off with nearly no problems thanks to the information on this forum.

Thanks again sr20forum,
 

·
Registered
Joined
·
3,442 Posts
the force is strong my friend! what kind of car did u turbo?
 

·
www.FAIRTAX.org
Joined
·
8,920 Posts
Looks good Monty, have fun :)
 

·
<>< Jesus is the Answer
Joined
·
5,518 Posts
sr20det808 said:
the force is strong my friend! what kind of car did u turbo?
looks like an egg

welcome to boost, Im not there yet but hopefully I will be soon.
 

·
SR powered S13 coupe
Joined
·
6,728 Posts
Discussion Starter · #7 ·
sr20det808 said:
the force is strong my friend! what kind of car did u turbo?
Thanks, it's a maroon egg... here's a nice clean picture of it.


Thanks guys for all the warm comments. The saga isn't over yet, my AC is interfering with my TMIC setup so the AC is going Friday night.

Oh yeah, don't forget to remove all remaining parts from the engine bay before going on your test drive... 2 miles from home at midnight last night while testing out the new turbo I hear a twang sound from the engine bay. Pull over inspect everything (without a flashlight... needle in a haystack senario), decided to continue on at idle to home.

1 mile later battery light and brake lights come on, so I inched home to find.....
...
..
.
drumroll please..... the alternator/AC compressor belt has snapped off and the PS and WP belt was shreaded but still functional. This stumped me and my roomate so we ran back out to the spot were we heard the sound and found an extra hose (old hose that I replaced during the process of turboing :redface: ) Somehow it never quite made it out of the engine bay and probably caught between the belt and pulley causing it to snap off.

I feel better that I know what caused the problem and will get the car back on his feet Friday night... Fiance is also happy that this is almost over with, she is getting anxious to see me again ;)



I want to give a special thanks to Drew (91DE+T) who helped me with most of my turbo install.

-Monty
 

·
WWJD
Joined
·
2,092 Posts
Welcome my Boosting brother!!!
 
1 - 8 of 8 Posts
Top