SR20 Forum banner

1 - 5 of 5 Posts

·
NX Lightweight Not SE-R
Joined
·
859 Posts
Discussion Starter · #1 ·
is there a fuse that makes all the power die? is a short gonna cut all power? im thinking netheir but what will kill every thing? batts ok alts ok starter hasnt given me any troubles. (backstory i reclamped some wires by the battery lights work[ed] the car clicked, no start. later neither.)

please i do want to pay for fix, but i dont know where to start.
thanks again
jere
 

·
PLAY MY HEAD, MONKEY!
Joined
·
9,943 Posts
check all the fuses both inside the car and inside the engine bay, replace the blown ones if any. that's a good start to trying to find your problem...
 

·
Registered
Joined
·
4,465 Posts
jere said:
is there a fuse that makes all the power die? is a short gonna cut all power? im thinking netheir but what will kill every thing? batts ok alts ok starter hasnt given me any troubles. (backstory i reclamped some wires by the battery lights work[ed] the car clicked, no start. later neither.)

please i do want to pay for fix, but i dont know where to start.
thanks again
jere
SO the car clicks and the lights work, but it doesnt start?

Or NOTHING WORKS?
 

·
Red line chaser
Joined
·
2,040 Posts
jere said:
is there a fuse that makes all the power die? is a short gonna cut all power? im thinking netheir but what will kill every thing? batts ok alts ok starter hasnt given me any troubles. (backstory i reclamped some wires by the battery lights work[ed] the car clicked, no start. later neither.)

please i do want to pay for fix, but i dont know where to start.
thanks again
jere
You may wanna check the fusible links up there by the battery also. IIRC, if the main one pops, you are left with next to nothing.
 

·
NX Lightweight Not SE-R
Joined
·
859 Posts
Discussion Starter · #5 ·
;)nevermind, ;) i changed 6 or 7 fuses , in her, nothing changed, she wouldnt start. the power was on and off for no reason i could find, it just blinked.
so i was like that guy in the movie "back to the future". "come on, baby start" i hit my head on the steering wheel, and promised her nothing but, "premo gas" amoung other things. :) to my amazement she fired up on my next turn of the key!! im not sure why, but my car works again ( along with alot lights i never knew i had :) ) i guess there must be a bad ground somewhere. the terminals on the battery are greasy, but clean. thats all i know. she good now and im leaving her, i guess.

thanks for trying
 
1 - 5 of 5 Posts
Top