SR20 Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
9,405 Posts
Discussion Starter · #1 ·
I installed my Ground Controls today, and the rear are making a ton of noise. When you push down on the rear, the bolt on the top of the shaft moves up and down. Here's my order of parts installed: top nut, gold washer, rubber grommet, top hat, Ground Control top, spring, bottom perch. Am I missing something? I looked on Sentra.net, but they installed Motivational upper hats, so I can't go by that picture. The one thing I did notice was the rubber piece between the Motivational hat and the GC top part.

 

·
Living up Boost
Joined
·
893 Posts
Hmmm...guess you didn't get the motivational rear spring mounts. I had the same problem with my left rear shock. I just had to tighten the top nut as much as I could to get the sandwich of parts squished together.

-saaby
 

·
Premium Member
Joined
·
9,405 Posts
Discussion Starter · #4 ·
I added a stock bumpstop between the GC top hat and the OE hat. That didn't fix it. I then went to the biggest speed shop around(Home Depot) and bought 12 washers and put 6 on each side. Noise fixed.
 

·
Living up Boost
Joined
·
893 Posts
Saaby,
Did we end up changing the order the parts were installed from what the directions said?
I know for sure that we used a different order than the directions. I just remember that we cut up the stock bump stop and used it as a rubber washer between the top hat and the metal washer that catches the strut rod. Then we used the tiny rubber washer that Motivational supplied between the top hat and the motivational rear spring mount. On top of the spring mount we used the stock grande' spacer. On top of that we used another metal washer. And ofcourse capped it off with the nut.

-saaby
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top