SR20 Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
349 Posts
Discussion Starter · #1 ·
Idles Like Its Not Gonna Make It. It Takes About A 1/8 Mile To Get To 3500 Rpm. Then It Dies. New Plugs, Wires, Resisters, Cleaned All Fuel Stuff Checked For Vaccum Leaks. ...nada. Any Ideas??
 

·
Registered
Joined
·
1,487 Posts
is this a swap, did it ever run right, what's your setup....
 

·
Registered
Joined
·
349 Posts
Discussion Starter · #5 ·
Just Drove It. Missing Like Crazy.brand New Plugs Are Blaaaaaack. New Cap And Rotor. Almost Feels Like Firing Order Is Wrong. Cap Is Numbered Though So I Know I Didnt Screw That Up. Still Barely Idles And Stalls After Any Throttle.
 

·
Registered
Joined
·
267 Posts
TYPEILL said:
Just Drove It. Missing Like Crazy.brand New Plugs Are Blaaaaaack. New Cap And Rotor. Almost Feels Like Firing Order Is Wrong. Cap Is Numbered Though So I Know I Didnt Screw That Up. Still Barely Idles And Stalls After Any Throttle.
Did you reverse the outer two wires on the TPS?
 

·
Registered
Joined
·
349 Posts
Discussion Starter · #7 ·
Im Not Doing The Work, Some Shop That Bit Off More Than They Could Chew Is. Im Really Just Grasping At Straws Now. It Seems Like All Of Their Remedies Include Me Buying Parts For Trial And Error. Im Gonna Head Over There Momentarily And Check That Out. Really...its Prolly Not Their Fault, There Arent Many Turbo Nissans Here...certainly Not Gtirs. Mostly Hondas Runnin Round These Streets But Im Paying For This Learning Experience. Nopi Is This Weekend And I Was Hopin To See What She'd Run. Doesnt Look Promising
 

·
Registered
Joined
·
3,442 Posts
^^ sr20 forum got some good members :)
 

·
Registered
Joined
·
2,493 Posts
What MAF are you using? If your using the USDM one then that is why. also the TPS wires make a difference too. Check the MAF part number. if it doesn't end in 54C00 then its the wrong one. the UDSM one will make it run so rich that it has no power.
 

·
Registered
Joined
·
349 Posts
Discussion Starter · #11 ·
This forum sure does have a whole lot of good members. i think it is the usdm maf. the tps is wired the same way it was before the swap. is it supposed to be switched? ill check for the 54c00. and you will recieve a callat 1;00 sharp. thanx everyone! its funny all of these local shops are like..."dude, put a my sticker on your car and well hook you up." but noone wants to help get it running. im anti-sticker but id make an exception for a forum 1.

todd
 
1 - 20 of 23 Posts
Top