SR20 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
Hey guys, I have 99 sentra se-L fully stock and im having an issue with the EVAP system. At first i had a check engine light so i read up the code and it read p1493. I searched what this code meant and it means canister purge control valve/ solenoid valve. I went to an advanced auto parts store and they said we don't sell sensors or anything for that system. That some emmission ish. lolz. They recommended me to go to the dealer. hahaha
I was wondering if anyone else had an issue with the EVAP system before or would know how to do a home diagnostic. Any kind of information would help. I am not familiar with this system at all. lolz

YOU GOTTA LOVE OBD2:biggthump

Thanks
 

·
Registered
Joined
·
102 Posts
Hey you need a evap vent valve soleniod. In the back of the car there is a plastic canister. There is a small switch 2 10mm bolts and a 2 wire plug in front of it. Take it off and bring it to the dealer parts dept with your vin# They will have it in stock they are cheap and go bad all the time. hope that helps.:biggthump

Is on the drivers side rear easy to get to.
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #3 ·
Thanks for the info man.I deffinently seen that before but didnt know what the heck it was. Im going to take it off and look at it. Hopefully if I get a new one the code will dissapear.

Thanks alot.
 

·
Registered
Joined
·
102 Posts
No problem. The CEL will not go off right away. Im not sure about nissans ecu but most cars will clear after 3 drive cycles with no fault. You can just leave your batt unhooked over night or the easy thing to do is just stop at advance auto parts and I think they clear it for free if you dont have a code reader.
 

·
Registered
Joined
·
18 Posts
I took mine out,sprayed it with WD-40,and touched power and ground to it a few times..worked great for over a year...then i had to replace it..lol It was stuck open.
New..about 120 bucks..ouch..now ya see why i tried the WD-40 first..lol
 

·
Registered
Joined
·
102 Posts
wow 120!!!! we have done them here for diag/part/labor for 130+tax ???? I think we are getting the part for like 50 or 60. Not 100% on that but I deff dont remember 120!!!:eek:
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #9 ·
No i didnt take out the switch yet. It keeps raining up here like every other day.
**** get to it next week. There is an se-l at a junkyard near my house. Im going to just take out the switch from that se-l and see what happens. I hope it works. I cant pass emissions and these cops are messing with me.
 
1 - 12 of 12 Posts
Top