SR20 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
722 Posts
Discussion Starter · #1 ·
Alright .. I need to know if this has happened to anyone before, and if so what's the fix.

When I have my headlights on 'low beam', my driver side headlight will be on low, but the passenger side headlight shines like it's on high beam. So when I pull the lever to high beam, the lights reverse; driver side is on high beam, passenger side is on low beam. If I put the lever somewhere inbetween hi and low, they will both turn on high beam.

What can I do to fix this? It's somewhat ghetto-tastic driving around at night. :-\
 

·
70/30 Racing
Joined
·
2,372 Posts
Switch the wires on the bulb harness.
 

·
Too busy to post
Joined
·
600 Posts
pdr said:
did..nothin happened. :-\
Which wires did you switch... :confused:
From what I remember the Middle wire is the ground, and the two sides are power, one for high beam one for low(don't remember which is which). To determine which is which use a light tester or voltmeter. Put your low beams on and check which wire is getting power on your drivers side. Then see if your passanger side is the same. If it is then you may have the wrong bulb, check around the rim of the bulb to match the #'s to the drivers side (don't touch the glass of the bulb with your fingers!). If it isn't then switching the two power wires on the passanger side should solve the problem.

I'll post which wires are which tommorrow if I have time to check my car tonight. Hope this helps.
-Ro
 
1 - 4 of 4 Posts
Top