SR20 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hey guys,
My buttons for the air circulation control (ie to select flow to the head, feet, windscreen etc) and the air ventilation (the open or close) have stopped working. I can press the buttons, but they don't have any effect. The green indicator light on the bottom of the buttons also don't show up, they're just blank.
I can't direct the air flow or close the circulation (it's on head and circulate atm), so it get's bloody cold at night with the cold air flowing in! :(
Is there a fuse for the controls? The heater and the fan speed controls still work.

Grrr it was working this morning, and has never had problems before. I was playing with my rear wiper motor today because it's stuffed, could I have triggered something?

Thanks.
:)
 

·
I love Katamari
Joined
·
1,187 Posts
I'm not sure you'll get too much help - the NX's have slide levers instead of buttons

it sounds though like it might be a fuse - check the owners manual for fuse box location
 

·
Registered
Joined
·
617 Posts
Australian NX's have the push button controls for fresh/recirculated air......but I have no idea what makes 'em work. I'd check for fuses first, other than that is there an electric motor or something that makes the flap open/close?? If so maybe it's faulty.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
Doh! I thought you had the push button type in the US. I've checked all the fuses and all of them were intact. Although one was blown - a 10A r/c mirror, but that had no effect.

I guess I'll ahve to ask Mr Nissan on the way to Uni today.

Thanks guys.
 
1 - 4 of 4 Posts
Top