SR20 Forum banner
1 - 10 of 10 Posts

·
vincit omnia veritas
Joined
·
1,085 Posts
Discussion Starter · #1 ·
OK, I isntalled the BB det t25 setup on my 10:1 cr sr20... runs good, boosts strong.. but...

ON startup it takes 10 secs of cranking to make it start... ICK! I cannot remember.. was there a recall on nx fuel pumps? I wonder.. car has 116k miles.. =)
Also, driving on occasion, stick it in neutral, one foot on the clutch other on the brake and the revs drop fast.. funny, because sometimes it dies (only done it three times in 130 miles of driving) and sometimes it bounces back.. any ideas?

I have some ideas on what it could be, leaky injectors (bad o rings? they looked good when I put em in and I lubed em before I put em in to make sure they did not get all tore up...) and I think the die to idle has something to do with the injectors and at the same time maybe a loose fitting vaccume hose? who knows! Car has no exhaust.. if that helps =) Normal backfiring (yeah yeah yeah!) on shift or whatever.. that goes away w/the exhaust

I am going to go check the plugs now.. getting a exhaust on monday
Thanks for your time!
David
92NX2kT
 

·
Veritas
Joined
·
6,205 Posts
David;

1.) If your fuel pump is shot, the car wouldn't start even after 20 minutes of cranking. So, it's probably not that.
2.) The clutching-and-dying thing also happened on my SE-R a few years ago. After that, I did a complete tune-up, including cleaning the TB, and since then it really hasn't happened. It has *almost* happened a few times, but the car saves itself at the last second.
Not much help, I know...

------------------
Greg Perry, '93 SE-R w/ 149,000 miles, JWT pop, header, ProActive
clutch, ST bar, NOS direct-port 75hp, Autopower 4-point roll bar/harnesses.
[email protected] 1/4 mile, [email protected] 1/8 mile, 1.98 60-ft.

My SE-R page, with videos
 

·
Not on fire... yet
Joined
·
591 Posts
whats your ignition timing set at?
 

·
vincit omnia veritas
Joined
·
1,085 Posts
Discussion Starter · #4 ·
<font face="Verdana, Arial" size="2">Originally posted by RacerX:
whats your ignition timing set at?</font>
~15 degrees.

I am 90% sure it is the injectors.. or fuel related. I am going to replace the injectors o-rings tomorrow afternoon, and I will let you guys know what's up.

When I start it, it takes 10 secs or so of cranking. If I start it, let it run (a year or a second) then wait a second then start it again it fires right up WITHOUT a big cloud that smells like gas...
When it has been sitting for any amount of time it is hard to start and it makes a big rich cloud..

I'll let ya know
david
 
G

·
I can almost guarantee you that it is your injectors causing the problem. I will bet that they are leaking and not allowing fuel pressure to build up easily when cranking the motor.

You should add a fuel pressure gauge between the fuel filter and the rail. Turn the car on, let it run for a minute, and then shut it off. The gauge should hold fuel pressure over at least 40 psi for a while, likle several minutes or maybe longer. If the fuel pressure falls, then you can conclude that either your FPR or your injectors are leaking. If you think it is the injectors leaking, remove the fuel rail and keep the injectors in place. Disconnect the electrical connectors. Turn the key "ON" and listen for the fuel pump to prime. If fuel leakes out of the injector pintles, then you have your answer. Also, you should try replacing the injector o-rings. There are 2 per injector.

This is somewhat common of the Bluebird motors I have seen. The original injectors leak like this sometimes. Who knows why? Anyways, not all BB motors do this, just a few that I have seen.

Good luck,

------------------
Jay Whitely
Tampa, FL
1996 200SX SE-R
GTi-R powered with F-MAX kit
 

·
vincit omnia veritas
Joined
·
1,085 Posts
Discussion Starter · #6 ·
AHHHHHHHH!!!!!
Ok, TWO leaky injectors.
replaced o rings.. no help, replaced them again.. NO HELP.

Car is not moving now, I am NOT going to run it with leaky ass injectors..

****.
David (BROKE from 550 for ic piping and exhaust today.. how am I going to buy injectors.. suck.)
 

·
Fmax Stg II B13
Joined
·
358 Posts
Remember we had this talk about getting what ya pay for, and sometimes the bang for the buck route, isn't
Just talking sh** while I can hehe
 

·
Registered
Joined
·
782 Posts
<font face="Verdana, Arial" size="2">Originally posted by SERprise In WV:
David;

1.) If your fuel pump is shot, the car wouldn't start even after 20 minutes of cranking. So, it's probably not that.
</font>

Actually, that is not true! I wouldn't trust boosting on a stock fuel pump with 116K. My fuel pump worked just great @ 98000 miles on it , Ben benavides and I drove to California from Arizona, got there, car ran fine for a day, drove to Group 5 Motorsports (Now AEBS) put the car on the dyno with the JWT 100 shot, BOOOOOOOM! Engine blew! Towed the car from San Diego, CA top Arizona, dropped a new Primera motor in, started it right up drove it around the block, startted sputtering, left me 1/4 mile away from the shop, towed it back to the shop, BAD FUEL PUMP! To make a long story short, the fuel pump will still be able to start the car, it just won't be able to hold fuel pressure like it should! I would NOT trust that fuel pump with that many miles! Pay $150.00 for a 190lph Walbro intank pump and be done with it!




------------------
http://members8.clubphoto.com/louis419830/439477/guest.phtml


Louis Anaya 1992 Sentra SE-R
349.6 hp & 301.9 ft/lb @ 19 psi, 12.0 @ 118.77, Bluebird SR20DET, T3/T04E, Deltagate Wastegate, FMAX Manifold, RevHard FMIC, JWT S3 Cams, JWT Ported & Polished Head, 1996 200SX SE-R Welded & Cyro Treated Tranny, ACT Xtreme P/PL & 6 Puck Disc, Cobra MAF, JWT ECU w/ 4 Bar Fuel Program, MSD 50lb/hr Injectors, JWT Fuel Rail, 300ZXTT Fuel Pump, AeroMotive Adjustable Fuel Pressure Regulator, Greddy Type "R" BOV, Greddy Profec B, Greddy Boost & EGT Guages, UR 4 Pulley Kit, Powerslot Rotors, Axxis MM Brake Pads, ES Motor Mounts, Topspeed Short Shifter, Momo Cobra Shift Knob, Autometer Shift Light, Fiber Images Carbon Fiber Hood, KYB AGX Struts, GC Coilovers (350F/600R)& 17x7 White Tenzo Shu-4's w/ Yokohama 205/40/ZR17 Tires (Street), 13x7.5 White Lenso VPD's w/ Mickey Thompson 24.5x8x13 Slicks(Drag)
 
1 - 10 of 10 Posts
Top