SR20 Forum banner
1 - 7 of 7 Posts

·
WASHED UP
Joined
·
2,440 Posts
Discussion Starter · #1 ·
hi i have a 92 se-r and .. my fans dont turn off ... as soon as i start the car it's on.... where i live its cold so it takes like 15 min to warm up... can any one help..???:(
 

·
pwnd
Joined
·
3,455 Posts
is your car running good? fans always on is part of the fail safe mode for the ecu. or have you ever unpluged them? I know ben acidently pluged the wrong thing into the fans once and they were on, he spent hours and days trying to figure that one out. pull your ecu codes see if anything is wrong by way of the ecu, then check your electrical connections.
 

·
WASHED UP
Joined
·
2,440 Posts
Discussion Starter · #3 ·
yea it drives good.. just the fan is always on.. it hesitates in the morning when its cold..sometimes cuts off.. when trying to start it but once its running no problems..
 

·
Premium Member
Joined
·
9,405 Posts
Stupid question: is the A/C switch on? The fans are always running when you have the A/C on.
 

·
WASHED UP
Joined
·
2,440 Posts
Discussion Starter · #5 ·
no its not a stupid question .. its a good question its off. thats the first things i check. may be a relay???
 

·
Jah Rastafari
Joined
·
7,677 Posts
You have a bad head temp senser or the plug that joins the head temp to the fans is disconected. This plug sits under the distributer depending on the year of the car the plug is either a 6 or 8 plug.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top