SR20 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter · #1 ·
Hey all. I have a 91 NX2000 that is having an issue at the moment. Yesterday while leaving work the car died on the way out when I was coming to a stop in gear with the clutch depressed. It sounded sort of like the car didn't recognize the clutch was depressed and so it killed it since it was stopped and in gear. I tried to restart it and the car wouldn't turn over. Pushed it back to the parking lot and got a ride home. Did some research and talked to some friends and most suggested that perhaps the small switch behind the clutch pedal that tells the car that the clutch is depressed wasn't being pushed all the way in. This morning I came into work and found that switch but even with me physically pushing it all the way in with my fingers, the car won't turn over. All other electronics are working. Any other suggestions?

It's not the fuel pump because I replaced that in December and it's getting no sound from the engine when you try and turn it over. It honestly is really like the clutch is just not engaged. I'm not good at electrical anything so any advice on what to check would be much appreciated.

Thanks in advance.
 

·
Registered
Joined
·
1,089 Posts
Replace the switch, if thats not possible. I have one that worked before I did the following and don't mind getting rid of it, wait, I can't remember if I have it or not, if you need it I will have to check to see if it is still there.

I disabled that switch by cutting the wires and putting them together, making the ecu think it is engaged at all times when I try to start it. Won't work for everybody, I never leave my car in gear. It is a PITA to reach and do the operation but it works.

So basically your saying that it does nothing when you try to start it, but it died for no reason? Any recent work done at all?
 

·
Puffy, perky piranhas
Joined
·
384 Posts
Stardust said:
Hey all. I have a 91 NX2000 that is having an issue at the moment. Yesterday while leaving work the car died on the way out when I was coming to a stop in gear with the clutch depressed. It sounded sort of like the car didn't recognize the clutch was depressed ....
I'm having similar kind of problem with my '92 NX2000. Sometimes, when the car is hot, when I come back out to start it -- no turnover. All other electric things function. if I turn on the lights and then try the key, they don't drop at all. This makes me think my starter is ok and it's that clutch switch.

After it cools of for a couple hours, starts right up.

weird.

I'm hoping it's the $27 switch vs. the $150+ starter
 
1 - 3 of 3 Posts
Top