SR20 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
362 Posts
Discussion Starter #1
So my motors got several broken rockers and a broken timing chain. If theres anyone in the DFW area preferably close to garland/rowlett who has any spare parts or engine or any help possible at this point would be amazing. Its a B13 with a JDM de in it. I think tomorrow i am going to try and remove the head to make sure the pistons are ok. Thanks if anyone can help in the next few days or atleast untill i can get it driveable
 

·
Registered
Joined
·
362 Posts
Discussion Starter #3
I got it all taken care of i just threw in my old stock high port motor in it. now ive got a bad idle bug biting me..........grr
 

·
Registered
Joined
·
362 Posts
Discussion Starter #5
yeah im gunna start working on trying to figure that out today. i know for sure that its not injectors or o2 sensors since i unplugged each and the rpm fell and the o2 is brand new.
 

·
Registered
Joined
·
362 Posts
Discussion Starter #7
nope no rewiring........ive been checking and swapping hoses with hoses off my other engine. Still no luck. its hard to try and get it into timing mode because when it gets near 2k the rpm gets kind of jumpy.
 

·
Registered
Joined
·
462 Posts
Damn it Jeremy!!! come over and fix my cars. Just Got a new B13 to play with, but damn I think my knuckle is **** up.
The G20 surge and drop idle too....prob clog fuel filter.
 

·
Registered
Joined
·
462 Posts
Tools....Apple salvage has a motor, you can rape it all you want. Engine still intact. Its on Mansfield hwy.
 
1 - 10 of 10 Posts
Top