SR20 Forum banner
1 - 5 of 5 Posts

·
Got Boost ?
Joined
·
328 Posts
Discussion Starter · #1 ·
Ok hears the deal i have a 92 classic and my gas mileage has gone to about 10 miles to the gallon and i have cheaked all the normal things and cant figure it out i have new plugs wires cap and roter new knock censer o2 censer witch keep comeing out with no tips on them ive cleaned the throtle body the egr valve the bpt valve and hose new fuel filter i think thats all oh ya and its inspection time ive never seen a car fail so bad my hc are 6.04 im alowed 1.20 co 111.0 im alowed 30.0 so if any one can help please do im going out of my mind thanx
 

·
vincit omnia veritas
Joined
·
1,085 Posts
do the plugs come out lookin the same? one cylinder more rich than the other? your car stumble and drive bad? Have you re-grounded your MAF sensor?
check the plugs.. replace if necessary(if you are having problems and fouling plugs pick up a set of bkr7e's.. coppers.. cheap and they work well..) and if the plugs are different.. one more rich than the other... take the fuel rail off and turn the ignition "on"(don't start!) and see if the injectors are leaking?

best of luck
 

·
Got Boost ?
Joined
·
328 Posts
Discussion Starter · #4 ·
I GOT MY POWER BACK and my emisions numbers look alot better still didnt pass somehow my base timeing slipped and i was running at 0 deg btdc has anyone else had this happen or know how to keep it from happening again
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top