SR20 Forum banner

1 - 20 of 24 Posts

·
NX2K Driver!
Joined
·
448 Posts
Discussion Starter #1
Hey I dont know to many members here But I thought I would share.

Last month I started my w10 DET swap In my g20.
I got the motor off a ebay seller for about $1100 shipped ($86 for shipping!)
This is how I got my motor. So clean looking



Well after getting the rest of the parts i needed and a lot of SEARCHING on here and many other forums I got to work. I did not jump into this thing without any clue on motors or nissans. I did a DE replacement in my brothers g20. and a motor swap in my old z31 with a 5-speed swap. So I have a clue.

So it went in nice, wiring was a dream almost a direct replacement. I had to fab up some IC pipping from a kit I got from a g20.net member. that also came with a type s BOV

me working on the beast



well I got it done and fired up in about 3 1/2 -4 weeks. I had my share of crap and problems but i think i did well here are some shots of her when i got done, These are old and I now have a OEM BB intake arm.





I will admit that this was a low cost swap, I spent about $2000 in total i think
Its Basic but works. I took it to a dyno dynamics and only got 142WHP at 151WTQ So I knew something was up. Well For the past few weeks I have been checking everything i can think of, I found a few boost leaks and a sensor unplugged. But that did not give it the power it should have. Then I was driving and noticed the sound of a exhaust leak. so i get home let it cool and have my friend crank it up and im looking and feeling and i find it... at the exhaust manifold to turbo and the j-pipe to to turbo... hell the bolts were about to fall out of the j-pipe and one was missing....:eek:

But now I have a concern, I removed my turbo to replace all the gaskets and clean things up a bit. Well Im waiting on my new gaskets i was removing the heat shield brackets. I turn my turbo upside down and then flipped it back and saw that oil was dripping out of the exhaust intake (part of the turbo that mounts to the exhaust manifold) Is this a bad thing? Or normal? It was running great before i pulled off the turbo so im not sure theres not any oil in or on my DP. any incite would be awesome. thanks
 

·
agent camel toe
Joined
·
9,396 Posts
sounds like a bad exh seal..mines did the same and i upgraded to a t28--theirs shops that rebuild them for $250 or so
 

·
NX2K Driver!
Joined
·
448 Posts
Discussion Starter #4
sounds like a bad exh seal..mines did the same and i upgraded to a t28--theirs shops that rebuild them for $250 or so
Oh please dont say that. I dont have the cash to rebuild this or buy another one....
 

·
merely a flesh wound
Joined
·
15,274 Posts
saw that oil was dripping out of the exhaust intake (part of the turbo that mounts to the exhaust manifold)
Are you talking about the 4 bolt flange? If so, it may be coming from the motor. What ecu are you running, and have you recirculated your BOV yet? You may be running very rich, causing the extra fuel to thin the oil down and getting a combination of oil and gas out of the exhaust manifold into the turbo. If it's still apart, swipe the gunk with your finger. Does it smell like gas?

C
 

·
Registered
Joined
·
226 Posts
Is the maf before the blow off valve? I thought that you were not supposed to do that unless it was a recirc blow off valve since you are blowing off metered air...
 

·
NX2K Driver!
Joined
·
448 Posts
Discussion Starter #7
Are you talking about the 4 bolt flange? If so, it may be coming from the motor. What ecu are you running, and have you recirculated your BOV yet? You may be running very rich, causing the extra fuel to thin the oil down and getting a combination of oil and gas out of the exhaust manifold into the turbo. If it's still apart, swipe the gunk with your finger. Does it smell like gas?

C
Yes its form the 4-bolt side. Im running a calum basic ecu and yes its running rich. I will check if it smells like gas.

\
Is the maf before the blow off valve? I thought that you were not supposed to do that unless it was a recirc blow off valve since you are blowing off metered air...
I did not recirculate when these pic were taken but soon after i got a oem u13 intake arm and recirculated the bov.
 

·
Tired!
Joined
·
10,149 Posts
Do you have teh restrictor in the oil line? COuld be putting to much oil to the turbo.

Brent
 

·
NX2K Driver!
Joined
·
448 Posts
Discussion Starter #10
Do you have teh restrictor in the oil line? COuld be putting to much oil to the turbo.

Brent
Ok Im a n00b, and this is all stock, If there is one on the turbo from Nissan it should be there.
 

·
merely a flesh wound
Joined
·
15,274 Posts
Well what's program is on the Calum, is it NA or Turbo, with the correct injectors and maf program?

C
 

·
huh??
Joined
·
3,407 Posts
That motor is from noth carolina right? if so, damn you. I was eyeing that engine for awhile, ans when I got the $$ it was gone
 

·
70/30 Racing
Joined
·
11,372 Posts
We did a similar swap to my brother's SE-R and had the same thing happen, except the car barely ran (idled fine, but wouldn't rev) and made a nice Spy Hunter-eque smokescreen. Turns out, the #3 cylinder was dead and was spewing oil into the exhaust.

Did you do a compression test yet?
 

·
NX2K Driver!
Joined
·
448 Posts
Discussion Starter #18
Yes its from NC. and I have not done a compression test, but they did and it checked fine(from what they say) I had planed to do so.
But the motor revs great and went all threw the power range. jsut lacking power. I am almost sure this was my power killer... somebody on g20.net said to check this along time ago. but i was lazy... and tired of working on this damn car... but i almost have it all in one piece. I will test it out, and it its the same I will get the t-25 rebuilt or get a t-28.
 

·
NX2K Driver!
Joined
·
448 Posts
Discussion Starter #19
As for alittle update I got a AEM wideband AFR guage and i installed it.
As for some who have not seen my car is a g20 with a white hood and a white trunk. I called her the panda, well now im going to paint it all black again tomorrow, so before I did i had a little fun with a cut that a friend made today. is crazy cool.

 

·
_______
Joined
·
3,640 Posts
Hey SR_Lucifer can you post up some pics of the avenir outlet pipe clearance on the x-member motor mount? Did you have to do anything special to get it to fit?

Edit: Nice clean swap by the way :biggthump

Thanks,
Mike
 
1 - 20 of 24 Posts
Top