SR20 Forum banner
1 - 7 of 7 Posts

·
Now accepting donations!!
Joined
·
3,394 Posts
Discussion Starter · #1 ·
I'm getting this high pitched whining noise when I accelerate, but the engine also makes the noise whenever I am in neutral and just rev it. I've been having some steering box problems lately (clicking when I turn the wheel while not moving- not axle clicking). I think my PS may have been leaking, I'm wondering if maybe a burnt PS pump would make this sound? Water pump? Any clues would be appreciated.


Oh and it's nearly impossible to hear listening under the hood, it's most predominate when accelerating. Generally doesn't start until about 4k.
 

·
Now accepting donations!!
Joined
·
3,394 Posts
Discussion Starter · #3 ·
yipeee :rolleyes: Just as I suspected. :squint:
 

·
i love b13's !
Joined
·
8,012 Posts
sure its not a roots supercharger making all that noise under the hood ? lol.

nah its prolly the powersteering or the alt. check the tention on the alt my old nx usta squak but adjusting it took the squek away.

stratton.
 

·
Registered
Joined
·
496 Posts
I wouldn't suggest this for the PS pump unless you're brave, but you can determine whether it's the alternator or not with a big screwdriver or pry bar or other long, straight metal thing. Just put one end on the alternator and your ear to the other end, and rev the engine by hand. If the alt. is whining you'll hear it loud and clear.

David
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top