SR20 Forum banner

1 - 12 of 12 Posts

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter · #1 ·
HKS EVC 1- three button(low-high-manual w/volume knob)

:confused: I cant seem to get it to work!! I have it hooked up as HKS tells me to. Someone with this EXACT boost controller tell me how you have it hooked up on an EXTERNAL wastegate. Right now i have it hooked up like the site says and its not opening the wastgate...and it just boost till i let off the gas(20+psi). Someone please help..i want to ENJOY my car :D :tongue:
 

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter · #2 ·
BUMP BUMP::: :confused:
 

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter · #4 ·
it doesnt have that on the back
 

·
BOOSTIN PROTECH STYLE
Joined
·
1,397 Posts
Make sure it's getting the boost signal from the turbo, double, tripple check your connections. Find someone with the direction, I never even messed with the HKS unit, only the Blitz and Greddy.
 

·
70/30 Racing
Joined
·
11,372 Posts
it could be for internal gates only.

try putting the boost controller so that it interrupts the signal going in the side port from the intake manifold. leave the top one unplugged.

if you are running your gate divorced, you can tell it is hooked up wrong because you will hear the gate opening under vacuum. dont ask me how i know. ****. :D
 

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter · #7 ·
WEll STeve you were right!!!! I called HKS today and there are switchs INSIDE the unit that i had to switch for external wasegate!!!!! It was set for internal!! Well i fixed that and DAMN this car hauls some ass! Pulls nice. Thanks for everyones help
 

·
70/30 Racing
Joined
·
11,372 Posts
Nismo91ser said:
WEll STeve you were right!!!! I called HKS today and there are switchs INSIDE the unit that i had to switch for external wasegate!!!!! It was set for internal!! Well i fixed that and DAMN this car hauls some ass! Pulls nice. Thanks for everyones help
how much boost you running? remember, no more than like 12 psi on pump gas. be careful with the dial-a-boom.
 

·
95NismoB14grl
Joined
·
1,492 Posts
Discussion Starter · #10 ·
running 15-16psi on 93 octane..
 

·
70/30 Racing
Joined
·
11,372 Posts
Nismo91ser said:
running 15-16psi on 93 octane..
stock 9.5:1 motor? thats pretty damned close to detonation threshold for me, just be careful, blowing motors isnt that expensive, but still sucks.
 

·
Registered
Joined
·
1 Posts
Sorry to bring up an old thread but I figured it was better then starting a new one.

I have a Hks Evc I with the same overboosting problem. I have a internal wastegate and apparently the boostcontroller is set to external.

Does anyone know which switch I neep to flip to set it to internal wastegate?

Regards
Martin
 
1 - 12 of 12 Posts
Top