SR20 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter · #1 ·
My ac has lost its R12 over the winter. I guess it is time to convert to 134, but I was wondering how much difference there is? I live in Texas where it gets pretty hot in the summer.
 

·
-
Joined
·
3,560 Posts
Mine didn't take. It lasted only about 6 months after "conversion." By a professional.
 

·
Premium Member
Joined
·
9,405 Posts
I converted mne to R134a myself, and it works fine. I replaced all the O rings. I took it to a friend of mine who does AC work, and he pulled a vacuum on the system, then added the coolant.
 

·
www.FAIRTAX.org
Joined
·
8,920 Posts
Eric, are all the Orings accessible from the engine bay? I have been thinking of putting the a/c back in the se-r and I was wondering if I had to pull the stuff from under the dash to change anything?
 

·
www.FAIRTAX.org
Joined
·
8,920 Posts
Oh shoot one last thing I forgot. Was your system "open" i.e. empty of coolant and not under vacuum for any length of time before the retrofit?
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #6 ·
It has never been completely open. It worked awesome last year, but was getting weak by the end of the year. Earlier this year it worked, but not well. Now it won't even engage, so I suspect there is not enough refrigerant to allow the clutch to engage. I would say it definately has a leak.
 

·
Registered
Joined
·
1,908 Posts
98_1LE said:
It has never been completely open. It worked awesome last year, but was getting weak by the end of the year. Earlier this year it worked, but not well. Now it won't even engage, so I suspect there is not enough refrigerant to allow the clutch to engage. I would say it definately has a leak.
It's not bad at all. Shoot me a PM I might have a line on some good ol r-12 for ya. Cheap!
 

·
Premium Member
Joined
·
9,405 Posts
paNX2K&SE-R said:
Oh shoot one last thing I forgot. Was your system "open" i.e. empty of coolant and not under vacuum for any length of time before the retrofit?

I only changed the O rings under the hood. I was afraid that one of the rings under the dash would leak, but its holding so far. My system was open for a few years. The guy I bought the car from had problems with it, and some shop put an aftermarket compressor and condensor on the car. When both didn't work, they gave him his money back, but took the parts off the car. I gathered the factory parts I needed, and put the AC system back on the car. I drained the oil in the compressor and put new stuff in.
 
1 - 10 of 10 Posts
Top