SR20 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter · #1 ·
Got them from www.coximports.com for $36 w/ shipping. Came in real fast (about 2 days).

Took of old pads and noticed that one pad was more worn then the other one (slot is not visible on one, while still visible on the other one). Not really that bad, but still something was obviously wrong.

"Oh maaan" - said I, as I thought that I have a frozen (6 months old) caliper. Well then I noticed that that one of the pins on that caliper didn't have a smooth shape (prob. due to rust). I sanded the pin down alittle bit to smooth it out and packed it with alot of grease. I hope that helps.

Brought rotors to get turned down for $20 bucks to local shop. Came back, installed everything. Turn on the car, no good! The car doesn't start! WTF! I didn't even open the hood... I started it after few more tries while pumping gas pedal. Everything's fine now, but what the heck could that be?

Checked fluid level and soaked some out. Broke pads in (from 45mph to 5mph). Really felt difference, especially after my worn generic ones with warped rotors.

Thats it... comments, questions welcome...
 

·
Registered
Joined
·
3,793 Posts
PNWser said:
Oxygen in the gas tank eh? :D :D :D
uh huh
or air is what he meant :) my car won't start after I fill up with gas sometimes, I have to pump the pedal a few times and it fires up and runs rough for a few seconds and it is ok after that. totally weired.
 

·
Registered
Joined
·
178 Posts
Discussion Starter · #7 ·
brian said:
or air is what he meant :) my car won't start after I fill up with gas sometimes, I have to pump the pedal a few times and it fires up and runs rough for a few seconds and it is ok after that. totally weired.
yep, thats exactly the symptoms...

anyways.. update...

I get the clicking/rotor touching pad sound from my passenger brakes at slow speeds with a light brake pressure... At first I though it was caliper pins, so I have polished them and applied alot of caliper grease, the sound was still there.... then Goodyear shop said it's warped disk and wanted to charge me $60 to fix it.. I said no and went to Meinike, where I have brought my rotors to get turned down... The guy there said that when he was working my rotors they were not warped, so it's probably my pads settling down... He told to come back in a week if problem persists, which I think it will...

I will keep everyone posted
 
1 - 7 of 7 Posts
Top