SR20 Forum banner
1 - 20 of 55 Posts

·
RIP Bob
Joined
·
1,757 Posts
Discussion Starter · #1 · (Edited)

B13 ECU PIN OUT


HERE IS THE WHOLE SPEED SENSOR DIAGRAM FROM SPEEDO TO ECU, YOU CAN SEE WIRE 32

PIN 32 is the speed sensor wire input, all you need to do is snip it and voila no more speed limiter on your U12, U13, W10, W11, GTi-R ecu. Now this is for a B13 ecu pin out, im not sure if the B14 is the same, also this is for manual trans cars, if you have a auto you might have some wierd stuff happen when rev cut comes. After you cut the wire make sure you atleast wrap some eletrical tape on the ends so it doesent make contact.

ORIGINALLY POSTED BY COACH
This wire has NOTHING to do with the speedo. The speedo runs off the electric speed sensor on the tranny that runs to a harness that goes through the driver fender and right to the gauge cluster. They are independent of each other.

 

·
Deviled Egg!
Joined
·
6,321 Posts
:D The secret is out!
 

·
Parting out my car
Joined
·
1,062 Posts
So this way the ECU would register a Speed Sensor error code; it wouldn;t see the speed output info passed from the speed sensor via the gauge cluster?

I was wondering about this. Should have 0 adverse effects, right? I mean, the flowchart for the ECCS systems show the input from the speed sensor as one of the inputs to the ECU to control fuel injection...but is its only REAL input to tell the ECU to fuel cut cuz you are going 'too fast' ?
 

·
RIP Bob
Joined
·
1,757 Posts
Discussion Starter · #8 ·
I doubt it has any effect on fueling, the only control im sure it has is to tell the ecu to cut fuel because your going to fast, ive never had any wierd stuff happen, just no speed limiter!
 

·
now on the West side!
Joined
·
3,661 Posts
Did you notice if this has any effect on your radiator fans? I remember looking at the FSM a while back and the fans shut off after like 62mph with a/c off, or 50mph with the a/c on.

I ask because my car tends to run a little hotter on the highway when I am sustaining 65+mph, but it always runs cooler when I'm just tooling around town. It doesn't matter if I have the a/c on or off.
 

·
RIP Bob
Joined
·
1,757 Posts
Discussion Starter · #11 · (Edited)
It will still read, if you have a 91-92 you have a mechanical speedo. 93+ was electric, my P10 is a 93 and my speedo still showed mph with the wire cut, so i dont know what it will do on yours, i say try it if you dont like it you can always hook it back up.
 

·
RIP Bob
Joined
·
1,757 Posts
Discussion Starter · #12 ·
Did you notice if this has any effect on your radiator fans? I remember looking at the FSM a while back and the fans shut off after like 62mph with a/c off, or 50mph with the a/c on.

I ask because my car tends to run a little hotter on the highway when I am sustaining 65+mph, but it always runs cooler when I'm just tooling around town. It doesn't matter if I have the a/c on or off.
No it didnt have any effect on my fans.
 

·
RIP Bob
Joined
·
1,757 Posts
Discussion Starter · #13 ·
My G20 is a 93 and it seems that it has a mechanical speedo, i think all highports were mechanical. Like i said in the original post im not sure about B14s, but this is for highport B13, P10's.

The wiring diagram is for a 94 B13 with a low port, thats why it shows eletric speedo.
 

·
Registered
Joined
·
2,292 Posts
My G20 is a 93 and it seems that it has a mechanical speedo, i think all highports were mechanical. Like i said in the original post im not sure about B14s, but this is for highport B13, P10's.

The wiring diagram is for a 94 B13 with a low port, thats why it shows eletric speedo.

my highport is electrical ;)
 

·
RIP Bob
Joined
·
1,757 Posts
Discussion Starter · #15 ·
looks like 93+ were electric, but my P10 is a 93 and its mechanical, must be a B13 thing.
 

·
Tired!
Joined
·
10,149 Posts
THsi wire has NOTHING to do with the speedo. The speedo runs off the electric speed sensor on the tranny that runs to a harness that goes through the driver fender and right to the gauge cluster. They are independent of each other.

brent
 
1 - 20 of 55 Posts
Top