SR20 Forum banner

1 - 10 of 10 Posts

·
The road's my slave
Joined
·
500 Posts
Discussion Starter · #1 ·
well last friday i was doing eighty on the hwy and suddenly a vx beetle stops and i slam on the brakes, the car skids/screeches for about s secs i turn to the left. downshift and take off. i noticed i got back up to speed and my ride was really bumpy i hope it's just the tires. but if you guys have any ideas please tell me.
 

·
The road's my slave
Joined
·
500 Posts
Discussion Starter · #4 ·
well i tightened up my lugs. that was okay. but could those flat spots be on all four tires or on just 2? cause i feel it more from my side (drivers)
 

·
www.FAIRTAX.org
Joined
·
8,920 Posts
If you locked up all 4 then all 4 are probably flat spotted.
 

·
Red line chaser
Joined
·
2,040 Posts
paNX2K&SE-R said:
If you locked up all 4 then all 4 are probably flat spotted.
And if that is the case (I think so also), then it's gonna be bumpy for a good while to come until you either get new tires or wear them down to the flat area.
 

·
Registered
Joined
·
1,591 Posts
yep...been there done that. Be sure that the calipers are still working. Part of my problem was one of the sliding pins was sticking after it happened, so we think it was holding the outer pad against the rotor and doing it at an angle. Just something else to make sure isn't going on, but it's prolly a flat spot problem. Have you taken the wheel off and rolled it yet?
 

·
The road's my slave
Joined
·
500 Posts
Discussion Starter · #9 ·
i haven't taken off the wheel yet but it's probably as flat spot. i dont think i have a caliper problem but i'll check just cause i'm using 1 caliper without the boot.
 

·
Registered
Joined
·
708 Posts
Yup itz a flat spot, happened to me in the one six.
 
1 - 10 of 10 Posts
Top