SR20 Forum banner

1 - 7 of 7 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I was driving home on the MAss turnpike this afternoon when something weird happened....I was driving pretty slow(40-50mph), because it was starting to snow out(again!), and my Classic started making this noise suddenly like I blew out my exhaust manifold gasket or soemthing. I immediately tried to pull over, but as those of you who travel the pike know, NOBODY will let you in! Anyway, it took me over a mile going 40-45mph to finally cut someone off to get in the breakdown lane. I open the hood, and their oil EVERYWHERE, smoking! I immediately notice that the oil filler cap on the valve cover, sitting on the valve cover itself. I know that that things torqued down well, because I always have a bitch of a time getting it off! Anyway, I luckily had an extra quart of oil and a rag in my car, and I cleaned things off as best I could, and added some oil(I lost about 1/4 of a quart), and drove home. Now, I seem to have lost some power....Please tell me I didn't seriously f**k something up! It would seem that I was driving with an "unpressurized" engine for a good mile or so without the cap on, not to mention the oil might have gotten into soemthing. Should I just bring it to a shop and have it checked out? Any assistance would be appreciated!!!!
 

·
Registered
Joined
·
244 Posts
Dude, I'm sorry to hear that, but I have never heard of anything happening like that to any car. If i were in your shoes, I'd take it(or tow it)strait to Nissan. but you can call around to shops and ask their opinion, they are usually very helpful.


Daniel K
93 NX2000
 

·
Registered
Joined
·
858 Posts
get a good shop to look at it.Hope all's well. unless you have the right tools to test for leakdown, compression test etc.

[This message has been edited by redman007 (edited 02-09-2001).]
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I just called my Mechanic 1st thing this am, and he said that while it's weird that it popped off like that, I didn't drive too far at a fairly slow speed, so everything should be OK. His only advice was to keep tabs to see if there was any oil burning or leaks in the motor itself. I feel better, but thank god it didn't happen while I was driving 75+MPH 10 minutes before this happened! Thanks for all your advice guys!!!!!!
 

·
pwnd
Joined
·
3,455 Posts
Well I dont know about a DOHC or our engine, but I did that to my dad's truck. Well he sorta did. He forgot to put the oil cap back on and we drove bout 20 miles at 65 when I noticed the smell of burning oil. We lost about 2 quarts to the top of the hood and thats it. I said lets check it before I left with the truck, the lid was off. So I put it back on after putting 2 quarts in it. But I dont see how it could have hurt the engine too bad, cause the cams are being sprayed with oil. That oil does splash up, lol take off the cap while running, I did
oil on my face. But other than something falling in there or just running unpressurized fully I dont see what harm it could do. But thats just an opinion, use your best judgement.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Actually, Jacen, that's exactly what I was going to do over the weekend-A complete oil change and system flush(can never be too careful)ASAP. Thanks again for all your input!
 
1 - 7 of 7 Posts
Top