SR20 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
When I start my car after it has sat for a few hours (long enough for the engine to get cold, but this problem doesn't occur when I first start it in the morning) and come to the first stop the idle sometimes bounces wildly between a near stall and about 1200 rpm. It settles out after a second or two and doesn't act up again. The IAC, throttle body, and MAF are all fine. A Consult-II diagnostic found the base idle to be set at 1125, and after the idle was adjusted to a proper 738 the problem was minimized but is still noticeable. What else could be a potential cause?
 

·
Registered
Joined
·
286 Posts
very strange.

my 92 SE-R does this also. but i contributed it to the fact that it has been doing it since a jdm swap in feb.2002.
i just thought it was normal for that engine, as the previous one didnt do that.

think it could be throttle position sensor?

youre making me wanna go check mine too.
if i find anything, ill let ya know.
 

·
Registered
Joined
·
1,796 Posts
Yup, I have the same problem as well. Did it dip really low or stall if you down shifted from 3rd to 2nd without getting the clutch out quick enough? The tech at the nissan dealership found that the plug that plugs into the TPS had its wires pulled out then glued back in with silicone. You should definately get your TPS/ wiring looked at.
 

·
Registered
Joined
·
1,796 Posts
Oh hmm...its an auto is it not? Then you probably wont be noticing the downshift problem...you should still get the TPS looked at anyway, they tend to be cheaper for autos than manuals.
 
1 - 4 of 4 Posts
Top