SR20 Forum banner

1 - 20 of 63 Posts

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #1
So I yanked out the MSD Digital 6+. As much as Id hate to admit it and face all of the I told you so's. I hope that the stock ignition lets the car run way better (to a certain point, I'm sure)

Is there anything special about the stock components of the ignition?

Like the transistor and coil...do their cases need to be grounded/touching metal or can they be mounted anywhere.

I plan on doing some more wideband tuning this weekend and see how the car acts on stock spark.


Any tips or last minute checks/reminders?
 

·
Team Tool
Joined
·
2,514 Posts
Just want to let you know my car is running strong on the Crane ignition.:biggthump :biggthump

Just ask Powder :biggthump

I also have 534 miles on the clock now. Oil change and dyno coming soon.
 

·
PLAY MY HEAD, MONKEY!
Joined
·
9,943 Posts
From what i've seen, MSD Dig. 6 is fine with the B14's and the Crane ignition is good with both b13's and b14's?
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #4
yeah the rumor I have is anything externally coiled, be it B14 or B13, the MSD doesnt perform as advertised.

Again, I really hope thats the case.

Anybody know where to get a Crane DSR (p/n: 6000-6424) for under $300?
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #5
Just want to let you know my car is running strong on the Crane ignition.:biggthump :biggthump

Just ask Powder :biggthump

I also have 534 miles on the clock now. Oil change and dyno coming soon.
youre barely changing your oil??

I did it every 50 miles up to 100. And now every hundred up to 500. Then every 500 up to 1500. Then switching to synthetic and commencing regular cycles...
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #6
Oh and I forgot, so can anyone confirm if the Transistor & Coil need a chassis ground? I have mine mounted on the driver side frame rail and the coil is just Zip tied to a PCV hose LOL
 

·
Premium Member
Joined
·
5,202 Posts
From what i've seen, MSD Dig. 6 is fine with the B14's and the Crane ignition is good with both b13's and b14's?
The dig 6 only works well on the B14. I tired the 6A, 7A, Digital 7, Digital 6 on my can and none worked well. Lots of low speed transitional boost driveabilty issues. The MDS was causing spark scatter.

B14's don't seem to have the problem.

A Crane igntion seems to work great on my B13
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #8
Yeah Thats what I hear and remember you saying.

My main problems seem to be at full boost when the gate is open or when I floor it and it reaches full boost.

My plug gap is tiny and if I open it more the car will run like total ass. I feel as if the spark is too weak.

This weekend should tell all. I hope the Crane is the solution. Then I can finally move on with my project.
 

·
Team Tool
Joined
·
2,514 Posts
Yeah Thats what I hear and remember you saying.

My main problems seem to be at full boost when the gate is open or when I floor it and it reaches full boost.

My plug gap is tiny and if I open it more the car will run like total ass. I feel as if the spark is too weak.

This weekend should tell all. I hope the Crane is the solution. Then I can finally move on with my project.
What do you cap and rotor look like?
 

·
70/30 Racing
Joined
·
11,372 Posts
Oh and I forgot, so can anyone confirm if the Transistor & Coil need a chassis ground? I have mine mounted on the driver side frame rail and the coil is just Zip tied to a PCV hose LOL
I am pretty sure they all have their own grounds built into the harness.

Don't you have a multi-meter?
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #12 (Edited)
What do you cap and rotor look like?
new....


word on the oil changes.


just cause I have a multimeter and can determine if the harness has a ground doesnt mean the case doesnt require a ground to prevent EMI...

you know EMI...the reason you get that whining sound on your car that increases w/ frequency as the engine revolves higher? :D
 

·
Team Tool
Joined
·
2,514 Posts
new....


word on the oil changes.


just cause I have a multimeter and can determine if the harness has a ground doesnt mean the case doesnt require a ground to prevent EMI...

you know EMI...the reason you get that whining sound on your car that increases w/ frequency as the engine revolves higher? :D
Or the reason your car has a 5k redline when free-reving. EMI no good, just put a ground wire on everything.
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #14
no emi here, sir.. My edline is well in th 7ks :) found that out the scary way last time I was wideband tuning..watching the LM-1 instead of the tach LOL
 

·
70/30 Racing
Joined
·
11,372 Posts
Meh, my car will keep going to 8500 or so RPM, despite the rev limiter, in 2nd gear...

My SE-R has a really high pitched electronic sound, but it's independent of RPM. Oh well, probably just the sound of power... :D
 

·
easy 400WHP
Joined
·
12,682 Posts
Discussion Starter #16
Its official,

MSD Digital 6+ + Turbo B13 = My hairy Anoose

Im able to run a bigger gap and fire all the way through full boost/rpm without hiccups on stock ignition and 1 Bar.

Crane DSR on the way....

I wouldve got around to the wideband tuning, but my damn wideband bung plug stripped out.

Now im waiting on an M18 x 1.5 Tap before I can do anything else.

One step forward, 2 steps back...but somehow thats good :D
 

·
70/30 Racing
Joined
·
11,372 Posts
****, you had enough money for the Crane, but couldn't go to the convention?

Assface...
 
1 - 20 of 63 Posts
Top