SR20 Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter · #1 ·
whats up guys, i went to the racetrack today and the best time that i have is 15.5, i have HS GEN 5, AEM cold air intake, S4 cams,hig flow cat, 2.5 mandrel bend exhaust,PS short shifter, 15 Kumho 711 with 26 psi on light weight rota rims. heres what i get:

R/T .026
60ft. 2.336
330ft 6.547
1/8 10.028
MPH 70.51
1000 13.007
1/4 15.563
MPH 87.52

I need your input,any advice? thanks.
 

·
Registered
Joined
·
379 Posts
not to be mean or anything but yes the times are slow for the mods.... when is the last time you had a tune up... you should def. be traping in the 90's with cams man.
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #5 ·
i just did a tune up about 5 weeks ago, any input how to improve my 60ft,?shifting? or my driving, im planning to run next week again and what is the best rpm to launch and to shift.... thanks guys
 

·
oh so LAZY
Joined
·
9,747 Posts
i ran almost the exact same with just 3 inch exhaust in my b14. was this your first run? my first run i ran a 16.4 i believe. so all you need is practice, and make sure you finish in 3rd gear, dont take the time to shift to 4th.
 

·
Registered
Joined
·
1,089 Posts
Are you running stock suspension, that would have alot to do with it.
 

·
Registered
Joined
·
1,089 Posts
Been a couple of months.......I launch at around 3500 and shift around 6800, With cams you could prolly wait just a hair longer, also, be quick about it. You lose alot of time in shifts. LOL, I practice quick shifts light to light, no I don't haul ass I practice quick shifts all the same.

Let some pressure out of your tires for better traction and on street tires stay out of the water box, just to the outside is plenty wet for street tires without getting water trapped in your treads.

this is only what I do and should be treated as such.
 

·
Carving Corners
Joined
·
484 Posts
I trapped 86 with just an intake with a high 2.5 60' and that was with a 16.2 ET. as others have said something is definatly wrong. your 60' isnt bad if you ask me. i would just keep practicing. youve got a nice collection of bolt ons there and i dont see why your car wouldnt be turning 14s with that setup.
 

·
Registered
Joined
·
807 Posts
do a tune up, clean your intake filter and check you timing. you should easily be running at least low 15s. by your trap it looks like it is your car and not your driving, unless your shifting way too early.
 

·
Tired Greasemonkey
Joined
·
1,384 Posts
n2nismo said:
do a tune up, clean your intake filter and check you timing. you should easily be running at least low 15s. by your trap it looks like it is your car and not your driving, unless your shifting way too early.
i agree, your timing may be the dirty culprit.
 

·
Registered
Joined
·
361 Posts
Was this at Sacramento or Infineon?
With your decent 60ft times and mods you shold be in the high 14s at about 92-93mph. The S4's should be loving the 2.5 mandrel exhaust. I traped at 86.9mph stock with no mods and a 2.4 60ft with a 16.1 ET.

Launch points very with different tires but 3500 is a good starting point, play around with it till you get into 2.2x 60s. As far as between gear shifts I always shift a redline.

Some of us are going to sacramento on the 24th think some of the drag gurus are gonna be out there.
 

·
Registered
Joined
·
361 Posts
Ok that may account for a mph or two in your trap speed. At least that was the case bfore they revamped the raceway, there was a slight up hill grade at the end of the track. I have not raced there since the remodel but it still looks up hill. Never liked infineon for drag racing.
I would say your car is still down on power though, check your timing.
 

·
just workin'
Joined
·
1,345 Posts
how is your clutch? i'd check that and the timing if you are up to date with your services, what is you base timing set at?
 

·
Turbo Grocery Getter
Joined
·
1,461 Posts
that trap speed seems really low with S4 cams. Shifting at 6800 may be hurting you, you should rev higher with S4's. Check timing too.

nathan
 

·
DBA/IT
Joined
·
1,231 Posts
schematix said:
whats up guys, i went to the racetrack today and the best time that i have is 15.5, i have HS GEN 5, AEM cold air intake, S4 cams,hig flow cat, 2.5 mandrel bend exhaust,PS short shifter, 15 Kumho 711 with 26 psi on light weight rota rims. heres what i get:

R/T .026
60ft. 2.336
330ft 6.547
1/8 10.028
MPH 70.51
1000 13.007
1/4 15.563
MPH 87.52

I need your input,any advice? thanks.


here's my timeslip (left side) from last year when I ran with just a HS CAI. I also took out 90+ lbs of crap out of the car (spare/jack/mats/used a G13 hawker battery/pass. seat/etc etc). My clutch was slipping hard on the shifts and I had a jacked up launch. This was the third time I've ever ran a 1/4 mile in my life so don't tease my R/T ;)

anyway I just thought I'd post my timeslip since it looks similar to yours. I think your trap speed should be alot higher with all your mods.
 
1 - 20 of 28 Posts
Top