SR20 Forum banner

1 - 12 of 12 Posts

·
PLAY MY HEAD, MONKEY!
Joined
·
9,943 Posts
Discussion Starter · #1 ·
Hey, i have a jwt turbo ecu right now that i was running on my usdm DE, t28, 3 bar, stock maf and 370cc injectors. it was also programmed for s3 cams. My question is will this ecu work still with my det swap, same injectors, t25, same maf, but no cams? TIA

Dave
 

·
SNAIL SQUAD
Joined
·
10,271 Posts
daveracer said:
Hey, i have a jwt turbo ecu right now that i was running on my usdm DE, t28, 3 bar, stock maf and 370cc injectors. it was also programmed for s3 cams. My question is will this ecu work still with my det swap, same injectors, t25, same maf, but no cams? TIA

Dave

Yes it will work. May have soem differences but, it will work.
 

·
Undecided
Joined
·
4,132 Posts
It will have a non aggressive timing curve for the low compression motor. You may want to run run a little more base timing and see how it feels. Since the MAF and the injectors are the same it will most definately work. Make sure to use USDM sensors and not the JDM sensors when you do the swap.
 

·
Devil's Advocate
Joined
·
1,156 Posts
97SE-R C2 said:
It will have a non aggressive timing curve for the low compression motor. You may want to run run a little more base timing and see how it feels. Since the MAF and the injectors are the same it will most definately work. Make sure to use USDM sensors and not the JDM sensors when you do the swap.
I run 16 degrees base timing with my JWT ECU programmed for 9.5:1 on my BB motor. No problems on 12lbs of boost. I also sent you 2 more PM's if you got them.
 

·
PLAY MY HEAD, MONKEY!
Joined
·
9,943 Posts
Discussion Starter · #5 ·
oNeBaDaPpLe said:
I run 16 degrees base timing with my JWT ECU programmed for 9.5:1 on my BB motor. No problems on 12lbs of boost. I also sent you 2 more PM's if you got them.
hey mike, send me emails instead because i don't get some of your messages and i don't know why. my email is [email protected]
 

·
Devil's Advocate
Joined
·
1,156 Posts
If it matters I also gap my plugs around .32.

Dave, email sent.
 

·
Devil's Advocate
Joined
·
1,156 Posts
It is high, but this JWT computer is crazy rich. It runs like a raped ape though. .28-.30 is usually normal.
 

·
Registered
Joined
·
317 Posts
i'm having mine re-done right now for the 8.5:1 DET engine. i was running the 9.5:1 program for a while and yes it ran fine. with my old set-up i would start to ping at 12psi on 93 gas, with the lower compression i ran 14-15psi with no pinging! but you could tell it was more sluggish at lower rpm's. hopefully the re-program will help. JWT said not to advance base timing to try to make up for it. (said may have too much timing at different rpm's) i was running 16-17* anyways, ran fine. i would like to dyno after the re-program to compare.
 
1 - 12 of 12 Posts
Top