SR20 Forum banner

1 - 9 of 9 Posts

·
NX2K Junkie
Joined
·
448 Posts
Discussion Starter #1
Well today I got my engine completed and the car back together. EVERY thing is perferfect. I went to crank the motor and it just cranked, so I took gas and poured it straight into the TB and the car fired right up, ran, then died due to no more gas. I then figured I had the fuel lines backwards... I did, changed them around and it still won't run. I've come to the conclusion that I have a problem with the fuel system on my new engine. There is gas and pressure in the fuel lines... I know I shot myself in the eye with pressurized gas. What do you think it could be? Fuel rail, injectors??? What should I do? I was thinking of swapping the whole fuel rail and injectors from the old engine to the new one. I don't know what else to do, im very bitter and stuck. Help!

------------------
Greg Taylor
Black 96 200SX SE-R
More info on my car
 

·
now on the West side!
Joined
·
3,661 Posts
<font face="Verdana, Arial" size="2">Originally posted by borguesian:
I know I shot myself in the eye with pressurized gas.
</font>
LMAO! that musta hurt. i don't know what's wrong, just thought i'd comment


hope you get her runnin though
 

·
Registered
Joined
·
420 Posts
Remind me again how you the old engine went by by? (just so I can guess why it may not be cycling fuel). I don't really know what to suggest other than double check that all your electrical plugs actually snapped when you put them together, and that your fuel lines are in the right place (fuel return on top IIRC).

Let me know what help I can be. I've done what you've done 3 times, so I would like to think I can help at least a little.
 

·
NX2K Junkie
Joined
·
448 Posts
Discussion Starter #4
The other engine had something go wrong internally, it knocked. I will take your advice and double check everything. I wasn't sure if maybe the injectors are stuck from the engine sitting for a long time.
 

·
Drive it like ya stole it
Joined
·
6,928 Posts
<font face="Verdana, Arial" size="2">Originally posted by borguesian:
The other engine had something go wrong internally, it knocked. I will take your advice and double check everything. I wasn't sure if maybe the injectors are stuck from the engine sitting for a long time. </font>
Try turning the ingnition on and off in 2 second intervels...I know on some fuel injected cars..you have to "prime" the fuel pump...leave the ignition on for 2 seconds...then turn it back off...just my two cents...



------------------
Got 5-th gear pop-out problem?(FROM TalkingEAR) http://www.petitiononline.com/44ndone/
Damn it...I want an SE-R...NOW I HAVE ONE!! Bone Stock though...: (
 

·
Recovering Rice Boy
Joined
·
1,176 Posts
hey borg...you got a description of what that knock sounds like? Im afraid im hearing things..maybe you can help set me straight so I can stop sweating these little sounds. Did the knock affect the driveability of the car?

------------------
96 200sx Rice Mobile! Bone Stock..he,he,he
 

·
Recovering Rice Boy
Joined
·
1,176 Posts
Thanks Borg....whoa! Man my engine sounds nothing like that...Im gonna consider myself lucky...But thanks for the link..Maybe I got some kind of exhaust leak....My noise is a lot deeper than that...Thanks again

------------------
96 200sx Rice Mobile! Bone Stock..he,he,he
 
1 - 9 of 9 Posts
Top